drop SDK into IDE

cancel
Showing results for 
Search instead for 
Did you mean: 

drop SDK into IDE

274 Views
hamedfatemi
Contributor I

when I want drop SDK into  IDE in the log file I see this error: cvc-complex-type.2.4.a: Invalid content was found starting with element 'toolchains'. One of '{core_slave_roles_definitions, toolchainSettings}' is expected. cvc-id.1: There is no ID/IDREF binding for IDREF 'com.crt.advproject.config.exe.release'.  !STACK 0   at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestFactory.createPackage(SDKManifestFactory.java:52) at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.addToMap(SDKManifestProvider.java:520) at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.access$0(SDKManifestProvider.java:515) at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$1.preVisitDirectory(SDKManifestProvider.java:376) at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$1.preVisitDirectory(SDKManifestProvider.java:1) at java.nio.file.Files.walkFileTree(Files.java:2677) at java.nio.file.Files.walkFileTree(Files.java:2742) at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.refresh(SDKManifestProvider.java:368) at com.nxp.mcuxpresso.core.datamodels.ui.jobs.SDKImportJob.doRefresh(SDKImportJob.java:324) at com.nxp.mcuxpresso.core.datamodels.ui.jobs.SDKImportJob.run(SDKImportJob.java:94) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

2 Replies

140 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

Hamed,


Besides, there is another point: before you download SDK, please make sure if you select "MCUXpresso IDE" in Configuration Settings. we need build SDK based on MCUXpresso IDE.
see attached video.
I remember the default tool chain is not MCUXpresso from my side. Please check.


Have a great day,
Jennie Zhang

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

140 Views
lpcxpresso_supp
NXP Employee
NXP Employee

First of all, note that MCUXpresso IDE can only be used with SDKs generated since the IDE was launched (late March).

Assuming that you are using a recently generated SDK, then it looks like there is an issue with the SDK you are using. Can you clarify the board / part that your SDK is for, along with all the other configuration settings you selected when generating it on mcuxpresso.nxp.com.

Regards,

MCUXpresso IDE Support.

0 Kudos