Debug Instance freezes after breakpoint when using FreeRTOS TAD

cancel
Showing results for 
Search instead for 
Did you mean: 

Debug Instance freezes after breakpoint when using FreeRTOS TAD

Jump to solution
650 Views
mlamberti
Contributor I

Hello,

I converted our project from LPCXpresso to MCUXpresso and enabled FreeRTOS TAD following the "MCUXpresso IDE FreeRTOS Debug Guide". The TAD works fine as I can see all tasks, their stack usage and runtime. But when I set a breakpoint and the debug instance halts I cannot continue execution afterwards. There is no error message, execution just does not continue and I cannot use "step into/over" or suspend/terminate in the panel. Buttons grey out and keep grey.

"Terminate" in the context menu of the Debug perspective works, but results in the LinkServer reporting

"No debug targets available

Reason:

All SWD targets are currently connected to other debug sessions."

on further starts of a debug session.

A restart of MCUXpresso is required to run the application again.

If I disable TAD via the macro 

#define configINCLUDE_FREERTOS_TASK_C_ADDITIONS_H 0

everthing works fine, but the TAD is not available.

Also I noticed that setting a breakpoint while a debug session is active and running gives the error "Breakpoint installation failed: suspend operation timeout.".

I am using the LPC1758 on our own evaluation board dLAN® Green PHY eval board II - devolo Business Solutions  and LPC-Link 2 debugger.

FreeRTOS is version 9.0.0.

Regards, Michael

0 Kudos
1 Solution
172 Views
lpcxpresso_supp
NXP Employee
NXP Employee

We typically distinguish TAD as being related to FreeRTOS plugin display, as opposed to the FreeRTOS stack backtrace you refer to here. It sounds like there's a launch configuration issue. You may see what appears to be confusing results in Stop vs. Nonstop mode. I recommend you debug FreeRTOS applications in Stop mode for the best results. Delete your launch configurations. Next, set Stop mode as the default. This is Window -> Preferences -> MCUXpresso IDE -> Debug Options (Miscellaneous). Uncheck the Enable Non-Stop Mode checkbox and push Apply. When you next create a launch configuration, Stop mode debug will be the default. Report your results.

Thanks and regards,

LPCXpresso Support

View solution in original post

2 Replies
173 Views
lpcxpresso_supp
NXP Employee
NXP Employee

We typically distinguish TAD as being related to FreeRTOS plugin display, as opposed to the FreeRTOS stack backtrace you refer to here. It sounds like there's a launch configuration issue. You may see what appears to be confusing results in Stop vs. Nonstop mode. I recommend you debug FreeRTOS applications in Stop mode for the best results. Delete your launch configurations. Next, set Stop mode as the default. This is Window -> Preferences -> MCUXpresso IDE -> Debug Options (Miscellaneous). Uncheck the Enable Non-Stop Mode checkbox and push Apply. When you next create a launch configuration, Stop mode debug will be the default. Report your results.

Thanks and regards,

LPCXpresso Support

View solution in original post

172 Views
mlamberti
Contributor I

Thanks for your fast reply!

Disabling Non-Stop Mode solved the issue.

Regards, Michael

0 Kudos