Cannot read/write on-chip peripheral registers of KL25Z

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot read/write on-chip peripheral registers of KL25Z

Jump to solution
390 Views
isaotakashima
Contributor IV

I started develop the project of the KL25Z using the MCUXpresso IDE.

I already install SDK_2.2_FRDM-KL25Z.zip and create new project.

I want to read/write on-chip peripheral register of the KL25Z such as SIM, MCG, etc.

But no show any peripheral module in Peripherals tab as below.

pastedImage_2.png

Please let us know how to show on-chip peripheral in Peripherals tab.

Best regards,

Takashima

0 Kudos
1 Solution
185 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello lsao,

How about restart your PC and also change to a new MCUXpresso workspace when open MCUXpresso IDE?

How about change to another project, and run it ?

I take a video about  about how to debug on my side.

If still can't , please reinstall it .

BR

Alice

View solution in original post

0 Kudos
5 Replies
185 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Takashima,

Please download your project, then check the register you want to view on "Peripherals+",

thus the register data will show in Memory view :

pastedImage_1.png

Hope it helps

Alice

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
185 Views
isaotakashima
Contributor IV

Dear Alice,

Thank you for your quick reply.

I downloaded project as below, but not any peripherals show in Peripherals+ tab window.

pastedImage_1.png

Please advise to show on-chip peripheral on Peripherals tab window.

Best regards,

Takashima

0 Kudos
186 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello lsao,

How about restart your PC and also change to a new MCUXpresso workspace when open MCUXpresso IDE?

How about change to another project, and run it ?

I take a video about  about how to debug on my side.

If still can't , please reinstall it .

BR

Alice

View solution in original post

0 Kudos
185 Views
isaotakashima
Contributor IV

Dear Alice,

Thank you for your reply.

I solved this issue. I use Debug icon to launch debug session, then not displayed peripheral module in Peripherals tab.

When I use Debug button in Quickstart panel to launch deug sessin, displayed peripheral module in Peripherals tab.

For detail, please see attached screen shot.

Best regards,

Takashima

0 Kudos
185 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Takashima,

Thanks for your sharing.

I recommend you always use the Quickstart panel to build , debug and anything  else.

And if you want to use the icon, please use the another one beside the green one , not use

the  green icon.

pastedImage_1.png

Hope it helps

Alice

0 Kudos