while i update code in the MCUxpresso IDE,got java.lang.NullPointerException error。

cancel
Showing results for 
Search instead for 
Did you mean: 

while i update code in the MCUxpresso IDE,got java.lang.NullPointerException error。

445 Views
steven_zhang
Contributor IV

 i created a RT1050 project by using MCUxpresso,if i do not initialize Peripherals,I can compile the project.after i  initialized Peripherals by using the Peripherals Tool  ,i got "java.lang.NullPointerException "error while updating code. is anybody can help me.

0 Kudos
6 Replies

239 Views
lpcxpresso_supp
NXP Employee
NXP Employee

To add to Felipe's reply, please also attach .log file from .metadata folder inside your workspace.

Greetings,
MCUXpresso IDE Support

0 Kudos

239 Views
FelipeGarcia
NXP TechSupport
NXP TechSupport

Hi Steven,

 

Could you please let me know the version of MCUXpresso IDE you are working on?

 

Regards,

Felipe

0 Kudos

239 Views
steven_zhang
Contributor IV

MCUXpresso IDE v11.0.1 [Build 2563] [2019-09-01]

0 Kudos

239 Views
FelipeGarcia
NXP TechSupport
NXP TechSupport

Hello Steven,

 

I tried to replicate your issue on my side but I could successfully compile the project after initialize peripheral using Peripherals Tool. Please check my steps below. I am using SDK 2.6.1

 

  • I created a new project.
  • Enable USB device component by going to SDK management.

pastedImage_2.png

  • Enable the USB peripheral using Peripherals Tool as follows.

pastedImage_3.png

  • Enabled the USBPHY1_CLK by using Clock Tool.

pastedImage_7.png

By doing this my project compiled correctly, could you please tell me if you are following the steps above on your side as well as the SDK version you are using?

 

Have a great day,
Felipe

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

239 Views
steven_zhang
Contributor IV

yes,it works if there is only usb ,if i add lcd and freertos ,get some error.  i tried to use examples ,and suceesed to build a emwin + lcd + hid + freertos project.

0 Kudos

239 Views
Lukas_Heczko
NXP Employee
NXP Employee

Hi Steven,

I guess in this case you refer to different problem that the one from the original question. Indeed, I'm able to reproduce compiler error when I create baremetal MCUXpresso IDE project with USB component and later switch the project from baremetal to FreeRTOS. I was able to resolve the compilation error in the project properties by removing "FSL_RTOS_BM" and "SDK_OS_BAREMETAL" symbols (these are the ones added during new baremetal project creation, however, they are not removed when switching to FreeRTOS):

pastedImage_1.png 

Regarding the null pointer exception from your original post, best would be if you could attach/send us the MCUXpresso IDE project and log file or exact steps how to reproduce the issue so we can analyse it. So far we were not able to reproduce it.

Thank you,

Lukas 

0 Kudos