ptp4l issue on LS1028ARDB

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ptp4l issue on LS1028ARDB

Jump to solution
5,569 Views
ceroone
Contributor II

Hello,

I am trying to synchronize some NXP equipment using ptp4l. It works fine for all the other boards, but I am facing a problem with the LS1028ARDB.

I run the following command :

# ptp4l -i swp0 -i swp1 -f /etc/ptp4l_cfg/gPTP.cfg

But it returns this error (besides the fact that the offsets remain very high):

ptp4l[xxxx.xxx]: clockcheck: clock jumped backward or running slower than expected!

Can you help me to identify what is the problem there?

Thank you.

cerrone

You will find the gPTP .cfg file attached below.

Labels (1)
Tags (3)
0 Kudos
Reply
1 Solution
5,529 Views
andrei_skok
NXP Employee
NXP Employee

Could you try adding 'step_threshold 0.00002' setting to the gPTP.cfg file pls and let us know whether the situation is improved ?
(for more info ref: https://github.com/openil/linuxptp/issues/10)

> So could this phc_ctl command be the cause of the problem ?
It seems that a large change in PHC is difficult to tune for, so these gPTP.cfg tunings should help.

View solution in original post

0 Kudos
Reply
7 Replies
5,546 Views
ceroone
Contributor II

In fact it was allready commented, I forgot to indicate it in my previous message.

Another thing that I forgot to say: before lauching ptp4l on each board, I also reset the PTP Hardware Clock. On the LS1028ARDB, the exact command that I run is:

# phc_ctl /dev/ptp1 set 0; ptp4l -i swp0 -i swp1 -f /etc/ptp4l_cfg/gPTP.cfg -m

(I reset the PHC on every board, but the LS1028ARDB is the only one on which I get the error message...)

So could this phc_ctl command be the cause of the problem?

ceroone

0 Kudos
Reply
5,530 Views
andrei_skok
NXP Employee
NXP Employee

Could you try adding 'step_threshold 0.00002' setting to the gPTP.cfg file pls and let us know whether the situation is improved ?
(for more info ref: https://github.com/openil/linuxptp/issues/10)

> So could this phc_ctl command be the cause of the problem ?
It seems that a large change in PHC is difficult to tune for, so these gPTP.cfg tunings should help.

0 Kudos
Reply
2,934 Views
justdomyself
Contributor II

my  test step is :

 

1、start the master   run  ptp4l  and  phc2sys

2、start the slave device , run  ptp4l  and  phc2sys

then slave system clock is sync sucsess by master., all this step  is run ok。

then i use  date  081515302023 to change master's time ,the time chagne maybe 1 minutes or more larger, maybe 1 hour or  one day.

 

then the slave device  print  error message:

clockcheck: clock jumped forward or running faster than expected!

 

So my question is ;

1、the ptp can't   chagne  master's time too large, It do not suporrt? My test method is wrong 。

(I do this is want to  confirm: the slave's time can change with the slave's time)

or 

2、the cmd I use i not corret, or the confiuge is not correct?  I use date cmd to change master's time 

so large is  ok, there is no problem?

 

can you help me anser my question ,thank you !

0 Kudos
Reply
5,502 Views
ceroone
Contributor II

Adding "step_threshold 0.00002" seems to solve the problem indeed.

Thank you !

0 Kudos
Reply
2,941 Views
justdomyself
Contributor II

Hi:

my slave device use cmd :

"ptp4l -f   ptp4l.conf -i eth0 -H -m -s"
 
I modify  ptp4l.conf file:
 
change step_threshold  value from defaut 0 to  0.00002,
 
but the error message is still happened?
 
 
 
0 Kudos
Reply
2,935 Views
justdomyself
Contributor II

my  test step is :

 

1、start the master   run  ptp4l  and  phc2sys

2、start the slave device , run  ptp4l  and  phc2sys

then slave system clock is sync sucsess by master., all this step  is run ok。

then i use  date  081515302023 to change master's time ,the time chagne maybe 1 minutes or more larger, maybe 1 hour or  one day.

 

then the slave device  print  error message:

clockcheck: clock jumped forward or running faster than expected!

 

So my question is ;

1、the ptp can't   chagne  master's time too large, It do not suporrt? My test method is wrong 。

(I do this is want to  confirm: the slave's time can change with the slave's time)

or 

2、the cmd I use i not corret, or the confiuge is not correct?  I use date cmd to change master's time 

so large is  ok, there is no problem?

 

can you help me anser my question ,thank you !

 

0 Kudos
Reply
5,556 Views
andrei_skok
NXP Employee
NXP Employee

In gPTP.cfg, please comment out the neighborPropDelayThresh line
# neighborPropDelayThresh       800

and let us know how you get on.

0 Kudos
Reply