LS1046a EMMC hardware question

cancel
Showing results for 
Search instead for 
Did you mean: 

LS1046a EMMC hardware question

567 Views
Contributor I

hi yipingwang

please refer my question https://community.nxp.com/thread/522478

emmc boot

In my first custom board  , sdhc_clk,sdhc_cmd have waveform,sdhc_data0 always pull low

In my second custom board, sdhc_clk,sdhc_cmd have waveform,sdhc_Data0 have waveform but ls1046a have no responding,and it keep reset.

Labels (1)
0 Kudos
19 Replies

5 Views
NXP TechSupport
NXP TechSupport

Please provide the processor connection schematics as searchable PDF for inspection.

0 Kudos

5 Views
Contributor I

hi ufedor

For confidentiality reasons, only circuits related to emmc can be provided.

0 Kudos

5 Views
NXP TechSupport
NXP TechSupport

Please provide RCW being used.

0 Kudos

5 Views
Contributor I

hi ufedor

RCW:

1 #PBL preamble and RCW header
2 aa55aa55 01ee0100
3 # RCW
6 #
7 080b000a 0e000000 00000000 00000000
8 00008888 40c04002 60000000 c1000000
9 00000000 00000000 00000000 004388de
10 00020500 00223002 00000096 00000001

Attachment is the emmc chip I use.

0 Kudos

5 Views
NXP TechSupport
NXP TechSupport

You wrote:

when I switch to emmc, I still can't read the ID information of emmc.

Does it mean that the emmc device is empty?

0 Kudos

5 Views
Contributor I

Judging from the phenomenon, all operations on emmc return 0xff. When I use fl_dump, the data returned is 0xff.

i don't know what you means emmc deviceis empty.

0 Kudos

5 Views
NXP TechSupport
NXP TechSupport

i don't know what you means emmc deviceis empty.

It does not contain a valid RCW.

0 Kudos

5 Views
Contributor I

there is a valid RCW source ,0x40. same as sd boot

0 Kudos

5 Views
NXP TechSupport
NXP TechSupport

The "RCW source" must contain a valid RCW.

0 Kudos

5 Views
Contributor I

yes , there is a complete RCW source &data in emmc .  

Refer to AN12081, even if there is no information in emmc, you can communicate with emmc through cw tap

My problem is that on my own board, the LS1046a cannot communicate with emmc by any method, whether or not there is a complete RCW.

0 Kudos

5 Views
NXP TechSupport
NXP TechSupport

yes , there is a complete RCW source &data in emmc 

on my own board, the LS1046a cannot communicate with emmc by any method

How this could be simultaneously?

By which method RCW was written into the emmc?

How can you check that the RCW is properly read out from the emmc during POR?

0 Kudos

5 Views
Contributor I

And here is the output of the hexdump u-boot-with-spl-pbl.bin.

0000000 55aa 55aa ee01 0001 1008 0a00 000e 0000
0000010 0000 0000 0000 0000 0000 8888 c040 0240
0000020 0060 0000 00c1 0000 0000 0000 0000 0000
0000030 0000 0000 4300 de88 0200 0005 2200 0030
0000040 0000 9600 0000 0100 5709 0006 0000 0000
0000050 5709 0406 0010 0000 5709 7801 0000 10e0
0000060 1809 0000 0000 0800 5709 1804 0000 9e00
0000070 5709 1c04 0000 9e00 5709 2004 0000 9e00
0000080 eb09 0013 1080 204e eb09 dc08 5000 8028
0000090 5709 5801 0000 0003 4089 9008 0401 0080
00000a0 5089 9008 0401 0080 6089 9008 0401 0080
00000b0 5709 5801 0000 0010 6109 c000 0f00 ffff
00000c0 0081 0000 000a 1400 201f d503 0000 8200
00000d0 0000 0000 8f50 0001 0000 0000 0000 7f00
00000e0 0000 0000 2d70 7f00 0000 0000 0071 1400
00000f0 3ea0 1000 4241 d538 303f f100 00a0 5400
0000100 203f f100 0081 4000 0160 5400 103f f100
0000110 01a0 5400 c000 d51e 1100 d53e 0c00 b240
0000120 1100 d51e 115f d51e 0c80 5800 e000 d51b
0000130 0008 1400 c000 d51c 7fe0 d286 1140 d51c
0000140 0004 1400 c000 d518 0081 8000 0600 d2a0
0000150 1040 d518 4241 d538 303f f100 00a0 5400
0000160 203f f100 00c0 5400 103f f100 0080 5400
0000170 f220 d539 0000 b27a f220 d519 000f 9400
0000180 03eb 9400 00a0 d538 fc01 d360 0081 c000
0 Kudos

5 Views
Contributor I

Sorry, I didn't make it clear.
Let me explain the situation of my board again.
First, I found that my board couldn't flash emmc through cw tap, and then I took off the emmc. I used the emmc writer to flash firmwarexxx.img to the 0x1000 position of emmc in advance. Then I soldered the programmed emmc to my board.
Then set cfg_rcw_src [0: 8] to 0x40, my board still can't get up.
Then I checked the waveforms of the cmd and data0 signals

cmd has a periodic signal that will repeat many times, no data0 signal is returned.

0 Kudos

5 Views
NXP TechSupport
NXP TechSupport

> Then I checked the waveforms of the cmd and data0 signals

> cmd has a periodic signal that will repeat many times, no data0 signal is returned.

Use a digital scope to check which data is read out from the emmc during POR.

0 Kudos

5 Views
Contributor I

Due to the outbreak in China, I can no longer check the waveform.
But I have measured the waveform before.

>Use a digital scope to check which data is read out from the emmc during POR.

During POR ,the data0 is always low,and data1-3 are always 1.4V

0 Kudos

5 Views
NXP TechSupport
NXP TechSupport

This could indicate some issue with emmc connection.

0 Kudos

5 Views
Contributor I

thank you .  Can you confirm my emmc Schematic is right?

I will check the layout and other reasons

0 Kudos

5 Views
NXP TechSupport
NXP TechSupport

RST signal of the emmc is not connected.

Refer to the LS1046ARDB-PB schematics.

0 Kudos

5 Views
Contributor I

hi @ufedor

my emmc ver is 5.1, but ls1046a sdhc emmc ver is 4.5,Are they compatible?

if not compatible,Can I use emmc version 5.0?

0 Kudos