LS1043ARDB Yocto U-Boot Bootable SD Card

cancel
Showing results for 
Search instead for 
Did you mean: 

LS1043ARDB Yocto U-Boot Bootable SD Card

Jump to solution
407 Views
aismail102
Contributor II

GOAL:

A fully bootable SD card with the LS1043ardb stock image that will boot on the LS1043ardb.

CURRENT STATE:

I built all the image components (kernel, device tree, u-boot-with-spl-pbl, and file system) with the Yocto Project using the instructions from LSDKYOCTOUG. I built the fsl-image-networking yocto image. I made the following modification to the ls1043ardb machine configuration to get u-boot-with-spl-pbl.bin.

UBOOT_CONFIG ??= "tfa-secure-boot tfa sdcard"
UBOOT_CONFIG[tfa] = "ls1043ardb_tfa_defconfig,,u-boot-dtb.bin"
UBOOT_CONFIG[tfa-secure-boot] = "ls1043ardb_tfa_SECURE_BOOT_defconfig,,u-boot-dtb.bin"
UBOOT_CONFIG[sdcard] = "ls1043ardb_sdcard_defconfig,,u-boot-with-spl-pbl.bin"

The bootloader is written to the SD card with the following:

sudo dd if=u-boot-with-spl-pbl.bin of=/dev/sdx bs=512 seek=8 conv=fsync

The FM microcode and QE microcode are written to the SD card with the following:

sudo dd if=fsl_fman_ucode_ls1043_r1.1_108_4_9.bin of=/dev/sdx bs=512 seek=18432 conv=fsync

sudo dd if=iram_Type_A_LS1021a_r1.0.bin of=/dev/sdx bs=512 seek=18432 conv=fsync

The bootloader does come up and I load the kernel and device tree from a partition (1) on the sdcard and loaded to RAM with the following:

 fatload mmc 0 0x82000000 Image

 fatload mmc 0 0x8f000000 fsl-ls1043a-rdb-sdk.dtb

I change the boot arguments to boot from a partition (2) on the sdcard that has the filesystem and boot with the following:

setenv bootargs root=/dev/mmcblk0p2 rootdelay=5 rw console=ttyS0,115200 earlycon=uart8250,mmio,0x21c0500

booti 0x82000000 - 0x8f000000

ISSUE:

The issue is the kernel panics. I have narrowed the issue down to the bootloader because if I use the bootloader on the NOR flash of the dev board, everything boots successfully. I have read through many threads that mention that I might be missing a PPA.itb. I don't see this generated in the Yocto build and I even tried to modify the ls1043ardb_sd_defconfig by removing "CONFIG_FSL_LS_PPA=y". I have attached the output of the kernel panic.

0 Kudos
1 Solution
402 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please use bl2_sd.pbl and fip_uboot.bin in images/ls1043ardb/atf/ rather than using u-boot-with-spl-pbl.bin.

Please deploy bl2_sd.pbl to SD card with the following command.

 sudo dd if=bl2_sd.pbl of=/dev/sdx bs=512 seek=8

Please deploy fip_uboot.bin to SD card with the following command.

 sudo dd if=fip_uboot.bin  of=/dev/sdx bs=512 seek=2048

 

View solution in original post

0 Kudos
2 Replies
403 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please use bl2_sd.pbl and fip_uboot.bin in images/ls1043ardb/atf/ rather than using u-boot-with-spl-pbl.bin.

Please deploy bl2_sd.pbl to SD card with the following command.

 sudo dd if=bl2_sd.pbl of=/dev/sdx bs=512 seek=8

Please deploy fip_uboot.bin to SD card with the following command.

 sudo dd if=fip_uboot.bin  of=/dev/sdx bs=512 seek=2048

 

View solution in original post

0 Kudos
398 Views
aismail102
Contributor II

Hi Yipingwang,

 

Thank you for the reply. I tried what you suggested and the bootloader seems to freeze after printing the following.

NOTICE: Fixed DDR on board

NOTICE: 2 GB DDR4, 32-bit, CL=11, ECC off
NOTICE: BL2: v1.5(release):LSDK-20.04-update-290520
NOTICE: BL2: Built : 13:52:31, May 18 2020
NOTICE: BL31: v1.5(release):LSDK-20.04-update-290520
NOTICE: BL31: Built : 13:52:31, May 18 2020
NOTICE: Welcome to LS1043 BL31 Phase

0 Kudos