Hi Community,
Using dynamic creation of DPDMUXs and DPNIs successfully, and generate the DPL by following commands:
- 8x ls-addni --fs-entries=8 --num-queues=8 -n
- source /usr/local/dpdk/dpaa2/dynamic_dpl.sh <dpmac.n> <dpmac.n+1> ... <dpmac.n+7>
- 8x restool dpdmux create <dpdmux opts>
- 8x restool dprc connect dprc.1 --endpoint1=<dpdmux>.n.0/1/2 --endpoint2=<dpmac.n>/<dpni.j>/dpni.k>
- restool dprc generate-dpl dprc.1 > dpl-8-dpdmux.dts
Update the static DPL with dpl-8-dpdmux.dtb (generate by dtc tool) for uboot to initiate MC layout.
The error shows as blow:
[E, mem_mng_get_phys_mem:655] MAJOR mem. manager memory allocation failed
[E, mem_mng_get_phys_mem:658] Required size 0x000040000 alignment 0x000000100 exceeds available memory for partition ID 7
[E, init_bman_bp:399, DPDMUX] ID[6] - dpbp_allocate_buffers(), failed to allocate dpbp buffers
[E, init_infrastructure:3750, DPDMUX] swlib_init_bman_bp : -12
[E, dpdmux_init:4487, DPDMUX] init_infrastructure : -12
[E, mem_mng_get_phys_mem:655] MAJOR mem. manager memory allocation failed
[E, mem_mng_get_phys_mem:658] Required size 0x000040000 alignment 0x000000100 exceeds available memory for partition ID 7
[E, init_bman_bp:399, DPDMUX] ID[7] - dpbp_allocate_buffers(), failed to allocate dpbp buffers
[E, init_infrastructure:3750, DPDMUX] swlib_init_bman_bp : -12
[E, dpdmux_init:4487, DPDMUX] init_infrastructure : -12
[E, resman_is_link_permitted:6375, RESMAN] Object wasn't found
[E, linkman_probe_cb:205] No common ancestor - Failed to connect dpdmux@6 and dpmac@9
[E, subnode_process:155] Probing module 'connection' return error code -1. Continue dpl processing...
[E, resman_is_link_permitted:6375, RESMAN] Object wasn't found
[E, linkman_probe_cb:205] No common ancestor - Failed to connect dpdmux@6 and dpni@15
[E, subnode_process:155] Probing module 'connection' return error code -1. Continue dpl processing...
[E, resman_is_link_permitted:6375, RESMAN] Object wasn't found
[E, linkman_probe_cb:205] No common ancestor - Failed to connect dpdmux@6 and dpni@7
[E, subnode_process:155] Probing module 'connection' return error code -1. Continue dpl processing...
[E, resman_is_link_permitted:6375, RESMAN] Object wasn't found
[E, linkman_probe_cb:205] No common ancestor - Failed to connect dpdmux@7 and dpmac@10
[E, subnode_process:155] Probing module 'connection' return error code -1. Continue dpl processing...
[E, resman_is_link_permitted:6375, RESMAN] Object wasn't found
[E, linkman_probe_cb:205] No common ancestor - Failed to connect dpdmux@7 and dpni@16
[E, subnode_process:155] Probing module 'connection' return error code -1. Continue dpl processing...
[E, resman_is_link_permitted:6375, RESMAN] Object wasn't found
[E, linkman_probe_cb:205] No common ancestor - Failed to connect dpdmux@7 and dpni@8
[E, subnode_process:155] Probing module 'connection' return error code -1. Continue dpl processing...
[E, dpl_process:527] Error while parsing 'connections'. Skip processing the rest of DPL.
[E, main:198] DPL processing failed; continuing...
Is there any limitation on the static DPL to support same layout as dynamic way?