D-Bus Error Running on Linux 4.19 TWR-ls1021a

cancel
Showing results for 
Search instead for 
Did you mean: 

D-Bus Error Running on Linux 4.19 TWR-ls1021a

120 Views
Contributor V

Hi,

I have a TWR-LS1021a eva board and with linux 4.19 kernel

when I ran dbus on this device I always encountered this error below: any one knows why?

$2 = (gchar *) 0xb2c05668 "GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.XXXXX.server was not provided by any .service files"

this is the debug statement from the gdb

I did previously fix the error regarding "Failed to open connection to "session" message bus: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11" 

Labels (1)
3 Replies

11 Views
NXP TechSupport
NXP TechSupport

Hello Elias Bitbaker,

What rootfs filesystem are you using?

Please refer to the following log when I run lsdk1909 rootfs filesystem.

root@localhost:/mnt/bin# /mnt/etc/init.d/dbus start
 * Starting system message bus dbus
   ...done.
root@localhost:/mnt/bin# ps aux | grep dbus
message+   534  0.0  0.2   5744  2936 ?        Ss   Jun30   0:00 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
message+ 26503  0.0  0.2   5612  2244 ?        Ss   19:02   0:00 /usr/bin/dbus-daemon --system
root     26524  0.0  0.0   2124   492 ttyS0    S+   19:03   0:00 grep --color=auto dbus

Would you please provide your console log including Linux Kernel booting up and all your operations under Linux?

Thanks,

Yiping

0 Kudos

11 Views
Contributor V

Hi Yiping,

The dbus is running now previously is due to a configure file under /etc/dbus-1/system.d/ needs to assign root permission to the policy user.

However, current issue is the CPU usage reaches 190% high every time while running my application on d-bus wonder if you have any suggestions to debug this?

===============================================

root@localhost:/etc/dbus-1/system.d# [ 1118.654731] Out of memory: Kill process 649 (demo-server) score 886 or sacrifice child
[ 1118.662690] Killed process 649 (demo-server) total-vm:1024472kB, anon-rss:905288kB, file-rss:0kB, shmem-rss:0kB

===============================================

root@localhost:/etc/dbus-1/system.d# ps aux | grep dbus
message+ 269 0.4 0.3 5992 3084 ? Ss 12:37 0:00 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
root 545 0.0 0.0 2120 532 ttyS0 S+ 12:40 0:00 grep --color=auto dbus

===============================================

0 Kudos

11 Views
NXP TechSupport
NXP TechSupport

Probably there is memory leak problem with your application, please debug your application with gdb.