SDK for LPC4370

Showing results for 
Search instead for 
Did you mean: 

SDK for LPC4370

Contributor I

I am trying to explore the ADC functionality in LPC4370 microcontroller and find it difficult to do a quick evaluation since I cannot find an SDK to download for this microcontroller family, except for the keil_iar file for LPCLink-2, which I am using.

I cannot start with simple examples by importing an SDK using MCUXpresso since there is nothing listed. Even when trying to start off as a new C/C++ project and import the "", I cannot access any c and h files as they do not seem to exist in the directories that were automatically created during the import process. They appear with a little yellow lock sign in front of them. Compilation fails first thing due to "fatal error: board.h: No such file or directory"

Can you advise?

0 Kudos
2 Replies

NXP TechSupport
NXP TechSupport

Hi, Ali,

I attach the package of LPC4370, pls unzip it, and use it with MCUXpresso tools.

This is the screenshot when you load the example.

As the following, you have to load the 1 and 2, and compile them, then load whatever you need.

Hope it can help you


XiangJun Rong



Contributor I

Thank you for your reply!

After looking into the output errors closely, it looks like by importing the library using the "" provided on your website, paths will not be set correctly for some reason, specifically the path for "chip_43xx_18xx", "brd_link4370" and "examples_43xx_18xx" folders. It was looking at the wrong directory, which in my case is \Documents. I extracted and placed the above three folders directly into \Documents and tried compiling. It worked!.. but after this tacky patching of mine.

There was clearly something wrong as it should have looked into the workspace folder, which in my case is located at \Documents\MCUXpressoIDE_11.4.1_6260\Workspace. After trying the zip file you attached, I was so glad that it worked right off the bat. It looked right into the correct directory and compiled everything successfully without having to patch things up.

Thanks once again!

0 Kudos