LPCXpresso54618 SDK example USART issues

cancel
Showing results for 
Search instead for 
Did you mean: 

LPCXpresso54618 SDK example USART issues

Jump to solution
282 Views
Contributor II

I am having issues with the LPCXpresso54618 SDK example usart_interrupt. I am unable to receive or transmit any data through the Putty terminal. I doubled check that I configured the Putty terminal correctly. I tried running other usart examples but I still get the same issue. Also I am using the LPCXpresso54618 board. Any help would be appreciative.

Tags (1)
1 Solution
27 Views
NXP Employee
NXP Employee

JP6 is a hardware jumper ... if you are using the on-board VCOM port (which you are I believe) then you need to ensure this jumper is NOT installed. Refer to the board user manual for more info. 

View solution in original post

0 Kudos
11 Replies
27 Views
Contributor II

Thank you Brendon and XiangJun for your assistance. The JP6 hardware jumper was installed. Removing it solved my issue.IssueResolvedPic.jpg

27 Views
NXP TechSupport
NXP TechSupport

Hi, I have tested on my LPC54618 board, I can see characters on the Putty tools.

I attach the configuration when you create a project, in the SDK Debug Console box, pls select Semihost instead of UART. Pls have a try.

Hope it can help you

BR

Xiangjun Rong

pastedImage_1.png

pastedImage_2.png

0 Kudos
27 Views
Contributor II

Thanks for your help with my issue. I followed your steps but I still have the same issues. The image below is my project settings.Capture.PNG

0 Kudos
27 Views
NXP TechSupport
NXP TechSupport

Hi,

Can you see the virtual COM number which is enumerated by PC?

BR

XiangJun Rong

pastedImage_1.png

0 Kudos
27 Views
Contributor II

Yes. I also tried using the serial terminal in the IDE and I am still experiencing the same issues.Capture3.PNG

0 Kudos
27 Views
NXP TechSupport
NXP TechSupport

Hi,

Can you use the other serial tools to have a try instead of Putty tools?

BR

XiangJun Rong

0 Kudos
27 Views
NXP TechSupport
NXP TechSupport

pastedImage_1.png

Pls try to configure the PTTY tools as above.

BR

XiangJun Rong

0 Kudos
27 Views
Contributor II

This is what I have done so far. I reinstalled the IDE and the device drivers. So now the com port has changed from COM8 to COM3. I tried using TeraTerm's serial terminal but I am still experiencing the same issue. I followed your steps to configure the PTTY tool as shown in the picture. However, I am still experiencing the same issues.puttyconfig.jpgputtyconfig2.jpg

0 Kudos
27 Views
NXP Employee
NXP Employee

Hi Shannon,

Just wanted to check that you dont have JP6 installed? This jumper disables the on-board VCOM so an external serial to USB cable can be connected at P4 without causing contention.

Regards,

Brendon

0 Kudos
27 Views
Contributor II

Thanks for your assistance with my issue. I don't believe that I installed JP6 but I am not 100% sure. I checked my files and could not find it. Are there any additional programs I need to install to get UART to work?

0 Kudos
28 Views
NXP Employee
NXP Employee

JP6 is a hardware jumper ... if you are using the on-board VCOM port (which you are I believe) then you need to ensure this jumper is NOT installed. Refer to the board user manual for more info. 

View solution in original post

0 Kudos