LPC8N04 i2c Demos from SDK 2.5.0 not working

cancel
Showing results for 
Search instead for 
Did you mean: 

LPC8N04 i2c Demos from SDK 2.5.0 not working

Jump to solution
157 Views
Contributor II

Hello,

I cannot get the i2c demos in SDK 2.5.0 working for the LPC8N04 (OM40002) demo board.

I have confirmed that I can successfully flash other applications and modify both the polling and interrupt demos with printf statements that indicate they fail to establish an i2c connection via pins 1, 3 and 7 (GND) on P4. I have also tested with 2, 4 and 8 on P3.

Are these demos working for NXP engineers?

Here is my set up:

  • One OM40002 running "lpc8n04devboard_lpc_i2c_1_interrupt_transfer_master" (or the master polling example)
  • A second OM40002 running "lpc8n04devboard_lpc_i2c_1_interrupt_transfer_slave" (or the slave polling example)
  • Wires connecting pins 1, 3 and 7 on P4 on the first board to 1, 3 and 7 on P4 on the second board (per the included doc instructions; also tried 2, 4 and 8 to 2, 4 and 8)
  • I have tried running the slave first, then the master as well as the master first and then the slave. I've also tried booting both at the same time.
  • Debugging from both machines I see that the master doesn't get past "Wait for transfer completed." (somewhere around lines 112-120 in the interrupt master example) and the slave doesn't get past "Wait for transfer completed." (somewhere around lines 97-102 in the interrupt slave example)
  • I have tried with P7 and P8 in SWD mode or GPIO mode, no difference
  • I am programming with MCUXpressoIDE, both 10.3.0 on a Mac and 10.3.0 on a PC
  • I am using the built-in debugger on the OM40002
  • SDK version is 2.5.0  (released 2018-12-17) 

Any ideas? See attached for what I understand to be P4 1, 3, 5 and 7, circled in red with pin headers soldered on. I have tried this across 4x different OM40002 boards, no luck.

Labels (1)
Tags (2)
1 Solution
16 Views
Contributor III

Did you add 1k pull-ups to the SDA and SCL lines? There's no mention of this in the example code but pull-ups are usually necessary for I2C.

View solution in original post

2 Replies
16 Views
NXP Employee
NXP Employee

Hi, 

Like Paul mentioned, there's some issue in the LPC8N04DEV board design, there's no external pull-up on the I2C pins.

Have a nice day!

Regards 
Sol 

17 Views
Contributor III

Did you add 1k pull-ups to the SDA and SCL lines? There's no mention of this in the example code but pull-ups are usually necessary for I2C.

View solution in original post