LPC55S69-evk(Rev A2) cannot be flashed by onboard link2 with Jlink firmware

cancel
Showing results for 
Search instead for 
Did you mean: 

LPC55S69-evk(Rev A2) cannot be flashed by onboard link2 with Jlink firmware

Jump to solution
165 Views
Contributor I

I bought a LPC55S69-evk(Rev A2) but it cannot be flashed by onboard link2 with Jlink firmware. 

The setting was working for my Rev A1 board. 

If I use CMSIS-DAP firmware for the onboard Link2, it works properly. 

If I use jlink OB firmware for the onboard Link2, it can attach debugger to the board, but it cannot erase or program the chip. 

I am using NXP Mcuxpresso.

Labels (1)
0 Kudos
1 Solution
43 Views
NXP TechSupport
NXP TechSupport

Hi Francis Yeung

Thank you for your interest in NXP Semiconductor products and
for the opportunity to serve you.
Please follow the steps which are demonstrated in the https://www.segger.com/products/debug-probes/j-link/models/other-j-links/lpc-link-2/  to update the Jlink firmware, then give a try again.

Have a great day,
TIC

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

View solution in original post

0 Kudos
4 Replies
44 Views
NXP TechSupport
NXP TechSupport

Hi Francis Yeung

Thank you for your interest in NXP Semiconductor products and
for the opportunity to serve you.
Please follow the steps which are demonstrated in the https://www.segger.com/products/debug-probes/j-link/models/other-j-links/lpc-link-2/  to update the Jlink firmware, then give a try again.

Have a great day,
TIC

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

View solution in original post

0 Kudos
43 Views
Contributor I

Hi Jeremy, 

I have done this. I am using the latest jlink OB firmware. But it cannot erase and program. However, it can attach to target and run debugger.

I do the same process on both A1 board and A2 board. A1 board works properly. But A2 board has this issue.

0 Kudos
43 Views
NXP TechSupport
NXP TechSupport

Hi Francis Yeung

Thanks for your reply.
I don't have the LPC55S69-EVK (Rev A2) on hand now, and I'll apply for one board and do the same testing for confirmation.

Have a great day,
TIC

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos
43 Views
Contributor I

Hi jeremyzhou

Sorry, I just release my Jlink software/driver is not the latest although the firmware of Link2 firmware is latest.

Now it is working fine. Thanks for your help.

0 Kudos