LPC553x ADC: missing codes in high resolution mode

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

LPC553x ADC: missing codes in high resolution mode

2,637 Views
danielholala
Senior Contributor II

Hello,

I tested single ended operation of ADC0 in high resolution mode (16-bit resolution) with LPC5536 (LPC5536-EVK). Test procedure followed the description here

It seems the ADCs of LPC553x device family exhibits the same behavior as the LPC552x family: ADC0 (and most likely ADC1) has approximately 3 missing codes out of 4 codes. In other words, the ADC misses three consecutive codes.

01.png

As the errata sheet notes, the LPC553x ADC misses codes even in standard resolution mode.

03.png

This was not the case for the LPC552x ADC. In this respect, the quality of the ADC has worsened.

 

0 Kudos
15 Replies

2,559 Views
danielholala
Senior Contributor II

Hello @RaRo ,

yes, .

  • Can you confirm my observations?
  • Will this issue (of missing consecutive codes) be addressed in a future hardware release?
  • Will there be a LPC55xx MCU with a "real" 16-bit ADC in the future?

Thanks.
Daniel

0 Kudos

2,425 Views
RaRo
NXP TechSupport
NXP TechSupport

Hello @danielholala,

Would it be possible to share with us a clear photo of your MCU?

Best regards, Raul.

0 Kudos

2,415 Views
danielholala
Senior Contributor II

Hello @RaRo ,

here's the requested photo.

WIN_20231027_09_15_40_Pro.jpg

Hope that helps.

Best regards,
Daniel

 

2,361 Views
RaRo
NXP TechSupport
NXP TechSupport

Hello @danielholala,

Just for double check, are you using the LPCXpresso5536 EVK for testing the LPC5536's ADC performance, right? If so, could you please tell us which revision of EVK you are using? 

In other case, could you please tell us more about your custom board? Are you using LDO or DC-DC converter? If it is possible, could you please share with us your schematic? 

Best regards, Raul.

2,357 Views
danielholala
Senior Contributor II

Dear @RaRo ,

I performed the test with the LPC5536-EVK. The top PCB side has "LPCXpresso55S36" (sic!) printed on it. On the bottom side there are stickers that read: "SCH-55007 rev A" and "700-55007 rev X1".

I have not yet designed a custom board. For the custom board I plan to use the LPC5536JBD64 with LDO configuration.

Thank you.

Best regards,
Daniel

2,332 Views
RaRo
NXP TechSupport
NXP TechSupport

Hello @danielholala,

Could you please tell us your EVK's jumper settings? Could you take a picture of the board or tell us which jumpers are placed? Is the default jumper configuration in place or have you done some changes in any of the jumpers? Thank you.

Best regards, Raul.

2,321 Views
danielholala
Senior Contributor II

Hello @RaRo ,

this is a picture of my board. I left most jumpers in default position. I only had to change two jumpers to enable I2C and SPI on MikroBus. I think those are JP51 (for I2C) and JP48 (for SPI).

IMG_E3457_Tele.JPG

 Hope that helps.
Daniel

2,296 Views
RaRo
NXP TechSupport
NXP TechSupport

Hello @danielholala,

Sorry to bother you again.

Just for double check, are you using the PIO1-9 (ADC0_IN0A) pin? If not, which pins of the ADC are you using?

Could you please change to another ADC pins for test the module performance? For example, could you try with the ADC0_CH3A (J132-2)? Are you having the same results?

Also, if possible, could you please provide us your ADC project?

Thank you in advance for your help.

Best regards, Raul.

2,276 Views
danielholala
Senior Contributor II

Hello @RaRo ,

For my measurements I used "AN" pin from "mikroBUS" (J7) header. This should be ADC0 Ch 0A according to the schematic. I admit that this pin pulls up the output of the voltage divider which provides the input signal to the ADC by 50 mV.

This is not the case on ADC0 Ch 3A (J132-2 or J9-1).

This is the result on ADC0 Ch 3A:

danielholala_0-1698941108070.png

This histogram has more of a gaussian distribution as the one in my original posting. Obviously this input pin is more suitable for testing the ADC. Still you can clearly observe that there are missing codes.

For your information, the voltage divider is a 10 turn poti with 2 kOhm connected to 3.3 V and GND and set to 1.6 V output. For drawing the histogram, I had to "drop" the results from the first two ADC conversions as they were way off. 

When I use two fixed resistors, i.e., 220 Ohm, I get the following histogram instead:

danielholala_1-1698941276225.png

Here, I did not need to drop any conversion results. I assume that is is because the impedance is better matched.

How can I provide you with my ADC project? Should I just zip up the project folder and attach it to a posting here?

Thanks.

Best regards,
Daniel

 

 

 

2,063 Views
RaRo
NXP TechSupport
NXP TechSupport

Hello @danielholala,

All the information you are sharing will be useful. Thank you.

How can I provide you with my ADC project? Should I just zip up the project folder and attach it to a posting here?

Yes, please. Could you please zip the project as you mentioned and attach it here?

Best regards, Raul.

1,975 Views
danielholala
Senior Contributor II

Here is the project, @RaRo .

Just change the line

const unsigned AVG_NUMBER_OF_SAMPLES = 128;

to "1" to disable software averaging.

Also, use a half of full scale input (about 33000 conversion value) so you get a meaningful histogram output (the histogram code is naïve and uses all of the memory which is not enough to cover full scale).

Can you work with that?

Cheers
Daniel

 

1,622 Views
RaRo
NXP TechSupport
NXP TechSupport

Hello @danielholala,

We have validated LPC55S36 ADC's data. Thank you for all the information provided.

  • Can you confirm my observations?

The internal team mentioned the following: "We suggest using a constant DC output as ADC input and using the LPC55S36's LDO mode (by default, the LPC55S36 runs in DCDC mode) to test the ADC and achieve better results."

  • Will this issue (of missing consecutive codes) be addressed in a future hardware release?

This issue has been reported to the team in charge to take in consideration these observations.

Best regards, Raul.

1,497 Views
danielholala
Senior Contributor II

Thanks @RaRo , I will test with LPC5536's LDO mode as soon as my custom board is ready.

Best regards;
Daniel

2,463 Views
RaRo
NXP TechSupport
NXP TechSupport

Hello @danielholala,

We are still looking at this. As soon as we have an answered, we will let you know.

Thank you again for your patience.

Best regards, Raul.

2,575 Views
RaRo
NXP TechSupport
NXP TechSupport

Hello @danielholala,

Do you have any technical question that we could help you answering?

Best regards, Raul.