MCU Bootloader for Frdm MKV31F

cancel
Showing results for 
Search instead for 
Did you mean: 

MCU Bootloader for Frdm MKV31F

270 Views
Contributor II

Hey,

I am trying to run an application(led_demo_a000) on on mkv31f board, but first I was wanting to run the bootloader. The steps I followed were similar to mentioned in MCU bootloader demo application. 

Issues:

1) Firstly I cannot write to address 00

2) It seems like I have been able to transfer the application files, but the application doesnt run.

3) In the document it mentions that with ( blhost.exe -p COM1 -- execute 0x1fffea11 0 0x20001718), RAM reserved area should get bigger, but doesn't happen in my case.

Note: I do see the application runs individually but not with the bootloader. I also tried to install flash loader in RAM, and then tried to install the application at 0xA000, it got transferred but didn't run. 

Please advice.

Thanks,

Sid

Labels (1)
0 Kudos
5 Replies

93 Views
Contributor II

Thank you Da Li!

I will have to do more research on this, but I realized that when I build it in Release mode, it works fine. But has issues in Debug mode. 

0 Kudos

93 Views
NXP TechSupport
NXP TechSupport

Hi,

I use the frdm-kv31's bootloader. It works well. When you download the bootloader, you can use the "KinetisFlashTool" to check if the bootloader works well and download your app. You can find the tool in "NXP_Kinetis_Bootloader_2_0_0\bin\Tools\KinetisFlashTool\win"

Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

93 Views
Contributor II

Thanks for the reply Da Li. I have tried using the KinetisFlashTool, and similar to blhost, it successfully uploads the application but I don't see the application running. I get the following message indicating the device was updated successfully. But the led still doesnt blink. 

Connected to device successfully!
Get device security state successfully(UNSECURE).
Updating image......
Update image successfully!
Reset device successfully!
Update process is completed.

Could you possibly advise me on the steps I shall take to get the application running. 

Thanks,

Sid

0 Kudos

93 Views
NXP TechSupport
NXP TechSupport

Hi,

I think you can use the debugger to confirm whether the app is placed correctly. Download the app without bootloader, and check the first several bytes. And then use flashTools to download. Check if the byte at address "0xa000" is the same as the app without bootloader. Please tell me where did you find the "led_demo_a000".

Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

93 Views
Contributor II

Hello there,

I feel like I have similar issue to this ticket( How to use Kinetis Bootloader 2.0 ). Where I am unable to run the demo application on the board, but I see boot loader and application successfully uploaded in the memory. I feel like the issue is transitioning to the application. I tried the solution of modifying is_boot_pin_asserted API in hardware_init_MKV31F51212.c to always return false. But it didn't help. 

Lastly, I just realized that app shows me current version as K2.7.0, whereas the SDK version I am trying to load is 2.6.0. Maybe I have not been able to flash the boot loader in first place. Could you also help me with flashing instructions for this particular board ( I was currently using MCU expresso IDE and flashing through GUI Flash tool button, and board board is connected via usb to my computer).

Please advice.

Thank you,

Sid

0 Kudos