custom board programming and debugging using frdm boards

cancel
Showing results for 
Search instead for 
Did you mean: 

custom board programming and debugging using frdm boards

639 Views
ronakpanchal
Contributor I

Hello everyone,

I am using KDS for project development.

My project's custom hardware contains the following controller with SWD connection carried out on them:

1.) MKL26Z256VLH4

2.) MKL25Z128VFM4

which are different from the MCU part number  of FRDM boards(KL26Z,KL25Z,K22F) i have used for development.

Programmed/debugged one KL25Z using another KL25Z board using SWD connection and working properly.

so, how to debug/program custom hardware using SWD connection of this FRDM boards?

I have found some stuff about USBDM for debugging custom board.

Is it required to have the hardware of BDM or can i debug directly using FRDM boards?

If Directly using FRDM is possible then,

I have the following problem,

Downloaded latest version of USBDM and driver.

After that when i am connecting my FRDM KL25Z board (loaded with USBDM_OpenSDA.sx), Gives error of USB device not recognize.

If not then any other option?

Please Provide inputs as soon as possible ?

Thanks in advance.

Regards,

Ronak Panchal

Tags (2)
0 Kudos
5 Replies

348 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi Ronak,

I'd like to share a thread with you and I think this thread can provide a completely new approach to program the custom board by using the FRDM board.

The link as below.

Using the Freescale Freedom (FRDM-KL43Z) to Debug other Boards | MCU on Eclipse
Have a great day,
Ping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

348 Views
pgo
Senior Contributor V

Hi Ronak,

I tested a FRDM-KL25Z with the following:

  • USBDM Driver USBDM_Drivers_4_12_1_Win_x64.msi
  • USBDM Firmware from USBDM Software USBDM_Drivers_4_12_1_Win_x64.msi

It installed fine and the BDM was correctly detected under Windows 10.  I have also used with Windows 8.

Can you provide more information on your system and check the version against the above?

The screen grab below show the detected BDM with the BDM interface and CDC(serial) interface.

bye

pastedImage_1.png

0 Kudos

348 Views
ronakpanchal
Contributor I

Hi Pgo,

Thanks for your reply.

I managed to install drvier and now my Device is detected as a USBDM interface, but not as a serial port.

I had programmed KL26Z board using ARM Programmer(utility available with USBDM) from KL25Z through SWD connection and working properly.

But i require to Debug the code, so i have gone through the steps for debugging using USBDM but i got error.

Can you please Provide your inputs ?

I am using the 4_12(latest version) of USBDM.

Also please share the steps for to debug using it in KDS for latest version.

Regards,

Ronak Panchal

0 Kudos

348 Views
pgo
Senior Contributor V

Hi Ronak,

Are you sure that you are using the latest version of firmware and drivers as described above?

When I signed the drivers there were some required changes in the drivers and the firmware that makes it very important that matching software and firmware are used.

Using the wrong drivers may result in the serial port not being present.

In any case the serial port can't be used with an external target as the required connections (Tx & Rx) and not present on the ARM debug connector.  It is only really intended for the on-board chip.

It is still possible to use semi-hosting with with printf()s when debugging an external target.

USBDM: Setting Up the FRDM-XXXX

bye

0 Kudos

348 Views
ronakpanchal
Contributor I

Hi Pgo,

I have installed following versions

USBDM :- USBDM_4_12_1_30_Win

Drivers :- USBDM_Drivers_4_12_1_Win_x64

I have tried to debug on board hardware of KL25Z with ".sx" file firmware bootloaded using USBDM.

But not able to debug it.

What should be the cause for this?

Regards,

Ronak

0 Kudos