Update from KSDK 1.3 to 2.4

cancel
Showing results for 
Search instead for 
Did you mean: 

Update from KSDK 1.3 to 2.4

Jump to solution
272 Views
thomas_kopp
Contributor I

Hello everybody,

I have currently a project running with gcc and KSDK 1.3 who compile and runs perferctly. I don't use any IDE to work and compile that project.

I want to update the KSDK version to the latest one (2.4) but i can't have something running even with trying to adapt the Makefile. If i remember well, i used KDS to compile the platform library in the KSDK 1.3, then i just added it in my project git repository and in the Makefile.

For the new version i don't know how to proceed. Is there any documentation which explain how to do because i am really lost?

Thank you in advance,

Thomas

0 Kudos
1 Solution
168 Views
victorjimenez
NXP TechSupport
NXP TechSupport

Hello Thomas,

When you build your SDK with MCUXpresso SDK builder you have the option to select your Toolchain/IDE. You can select GCC ARM Embedded or MCUXpresso IDE. MCUXpresso IDE is our newest IDE and it's the replacement of KDS. 

pastedImage_1.png

I highly recommend you to use MCUXpresso IDE. In the User guide you will find all the information you need on how to work with the SDK.  

Hope it helps!

Victor.

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

----------------------------------------------------------------------------------------------------------------------- 

View solution in original post

0 Kudos
1 Reply
169 Views
victorjimenez
NXP TechSupport
NXP TechSupport

Hello Thomas,

When you build your SDK with MCUXpresso SDK builder you have the option to select your Toolchain/IDE. You can select GCC ARM Embedded or MCUXpresso IDE. MCUXpresso IDE is our newest IDE and it's the replacement of KDS. 

pastedImage_1.png

I highly recommend you to use MCUXpresso IDE. In the User guide you will find all the information you need on how to work with the SDK.  

Hope it helps!

Victor.

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

----------------------------------------------------------------------------------------------------------------------- 

0 Kudos