Unable to debug Freedom K22f board in MCUXpresso IDE

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to debug Freedom K22f board in MCUXpresso IDE

641 Views
prasannanaik
Contributor III

Hi,

   I want to test a simple led blinky example code on Freedom K22f development board but i am unable to find the debug interface for connection in debug configuration. I have attached the screenshot of the debug configuration available to me. Please help in connectin gthe baord to MCUXpresso IDE. 

MCUXpresso version: MCUXpresso IDE v10.3.0 [Build 2200] [2018-12-03]

Thanks in advance!!!

Best Regards,

Prasanna

Labels (1)
Tags (1)
0 Kudos
9 Replies

288 Views
daniel_graser
Contributor I

I have...or better i had exactly the same Problem with a FRDM KL25 Board.   I use Win10.

and it did'n work to install the SDA from the Pemicro_OpenSDA_Debug_MSD_Update_Apps_2017_12_07.zip.

The solution for this Problem is to use Windows 7...in my case i used a VM virtual machine with win7 installed.

in Win7 the is a mass storrage device even when i not press the SW1 key when pluggin it on.....   

I pushed the button and connected it ...and then i copied the sda file in the mass storage device... repowerd it ...an then the Device is now available in the win device manager under Jungo --> PE Micro Open SDA Debug Driver  :-)

now click debug in mcuxpresso...and it work.

0 Kudos

288 Views
tirak
Contributor I

The same with me.

In my devive manager is a MBED Bootloader USB Device.

And I have a pemicrowindrv...

But no selection for debugging.

I'm finished with this unproffessional s h i t !

No documetation about how to use this board with debugger. This is not suitable to use with class B or class C medical software. 

We go now to Cypress or STM.

0 Kudos

288 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Marcus Günther,

   Do you also use FRDM-K22F board?

   If you meet the detail problems, you totally can create your own question post.

   About the FRDM-K22F board get start, please go to this link:

  Get Started with the FRDM-K22F | NXP 

  I don't know what the PC OS you are using, if you are using the win10, you need to update your on board K20 chip firmware, please go to this link find more details:

OpenSDA Serial and Debug Adapter | NXP 

If you still have questions, please kindly let me know.


Have a great day,
Kerry

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

288 Views
tirak
Contributor I

Hi Kerry,

thank you for your answer.

I invested now 1h again. No sucssess. Wasted time again. I have no time for this. This is too expensive!

The money for this board is ridiculous as opposed to the money for the wasted time. So it's ok.

It is in my bin now :-D

As I told... I use Cypress now. I installed it, I connected it, I pressed built and debug... it works !!!

No wasted time...

So sorry

In one of your links is written:

"It has been reported that OpenSDA v2/2.1 bootloader could be corrupted when the board is plugged into a Windows 10 machine."

So it is maybe a system for vintage developer who uses WinXP or Win7.

But thank you for yor help

Marcus

0 Kudos

288 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Marcus Günther,

   Thank you for your updated information, and sorry for the inconvenience we bring you.

   It's no problem you are using Cypress now.

   But, when you have time, if you still have interest in your kinetis board, we can discuss about your problem again.

   I don't know which PC OS you are using, really win10?

   If yes, you need to find another debugger, eg JLINK, to download the new updated bootloader firmware to your K20 chip through J12 :

https://www.nxp.com/assets/downloads/data/en/snippets-boot-code-headers-monitors/0244_k20dx_bl_0x800... 

  The FRDM-K22 on board firmware is the old one, that is the known issue with win10, as you know, the FRDM-K22 board is also a little old board.

   Anyway, if you have any updated information or need any help from my side, just create the question post, and let me know, I would like to help you to get out.

Have a great day,
Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

288 Views
BlackNight
NXP Employee
NXP Employee

Hi Prasanna,

First, make sure you have the USB cable connected to the USB port on the board near the K20.

Second, use the 'blue' debug icon, this will automatically discover attached debug probes:

pastedImage_1.png

Or have a look at MCUXpresso IDE: Unified Eclipse IDE for NXPs ARM Cortex-M Microcontrollers | MCU on Eclipse  for an overview.

I hope this helps,

Erich

0 Kudos

288 Views
prasannanaik
Contributor III

Hi Erich,

   Thanks for your input. I have connected the usb cable to the board as well as the PC. I did try using the blue debug icon but got the following message

Debug Problem 1.jpg

Best regards,

Prasanna

0 Kudos

288 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Prasanna Naik,

   Please check your device manager:

pastedImage_1.png

Can you find the debugger?

If you can't find it, please refer to Erich's reply, you may need to update the on board K20 firmware:

OpenSDA Serial and Debug Adapter | NXP 


Have a great day,
Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

288 Views
BlackNight
NXP Employee
NXP Employee

This means it does not detect any debug probe attached. Are you sure you have a debug firmware loaded on your K20 of the FRDM-K22F board? Or are you using Windows 10 and the device shows up as BOOTLOADER or MAINTENANCE on your host? In that case your Windows 10 might have erased the debug application/bootloader?

If this is the case, you have to reprogram the K20 with a debug probe, see

Recovering and Updating the NXP OpenSDA Bootloader with P&E Multilink and MCUXpresso IDE | MCU on Ec... 

In addition to that, I recommend to stop the windows search as described in Recovering OpenSDA Boards with Windows 10 | MCU on Eclipse 

I hope this helps,

Erich

0 Kudos