Problem with KL46Z256 and Kinetis

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with KL46Z256 and Kinetis

Jump to solution
504 Views
beezee
Contributor III

Hi,

I have been trying to use Kinetis to debug KL46Z256 and I receive an error:

pastedImage_1.png

pastedImage_2.png

What I have done so far:

1. Install on different operating system

2. Update the bootloader

3. Update the kinetis

4. check the KL46Z256 drivers.

5. Change the cable and USB port

6. Change the kl256 with a different kl256

7. I get a similar error with Code Warrior as well.

I can program KL256Z with the mbed online compiler and no problem.

Can anyone help? 

Bee Zee

Tags (2)
1 Solution
180 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Bee Zee,

   Thank you for your updated information.

   I think you modify the FRDM-KL46 board before, because, when the FRDM-KL46 out of factory, the J18 is connect.

  If J18 is disconnected, normally, use the on board debugger to program the external chip.

   Now, if your problem is solved, please help to mark the correct answer, just to close this case, thank you!


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

3 Replies
180 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Bee Zee,

   Do you mean you are using FRDM-KL46 board, just use the on board debugger, and program the debug as the opensda, but this on board opensda can't program the on board KL46 chip? Or you can't program the external KL46 chip?

  Please help me to confirm the question.

I have test my FRDM-KL46 board, use opensda firmware, it works OK.

Please check your FRDM-KL46 board, you must make sure j17 is short, or R2, R1 is connected.

pastedImage_1.png

This is my test result:

pastedImage_3.png

pastedImage_2.png

You can try my attached project, then test it on your FRDM-KL46 board, if you still have problem, please let me know.


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

180 Views
beezee
Contributor III

Thanks, your advice helped me to find the problem. J18 was disconnected on FRDM-KL46Z so I connected it.

Thanks,

Bee Zee

0 Kudos
181 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Bee Zee,

   Thank you for your updated information.

   I think you modify the FRDM-KL46 board before, because, when the FRDM-KL46 out of factory, the J18 is connect.

  If J18 is disconnected, normally, use the on board debugger to program the external chip.

   Now, if your problem is solved, please help to mark the correct answer, just to close this case, thank you!


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post