NXP Touch Tuning not Opening Properly in FreeMASTER

cancel
Showing results for 
Search instead for 
Did you mean: 

NXP Touch Tuning not Opening Properly in FreeMASTER

295 Views
arunsharma
Contributor III

Hello Everyone.

I am new to the NXP and I have to use NXP micro MKE15Z in a project for touch-related application.

I found one tool for Touch Tunning but it's not working with FreeMaster 2.5 and also with the latest 3.0.

Can anyone please help me in understanding how it will work?

FreeMASTER project is available under the following path of the SDK

SDK\MKE15Z256xxx7_SDK\middleware\touch\freemaster\NXPTouchKE15.pmp

When I open this file I get a lot of errors in running the javascript files.

Problem-1.PNG

And Finally after clicking on "Yes" multiple times it looks like this.

Problem-2.PNG

Please suggest, what I am doing wrong.

Thanks in advance.

Labels (1)
0 Kudos
3 Replies

162 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi me.arunsharma07@gmail.com ,

  I have installed the freemaster2.5, when I open NXPTouchKE15.pmp which you have mentioned, it displays like this:

pastedImage_1.png

pastedImage_2.png

The system requirement is:

System Requirements

      FreeMASTER 3.0
    • Host side operating system: Windows XP to through Windows 10 32/64bit.
    • Hard drive space: 455 MB.
    • Required hardware: Serial RS-232 port for local control or USB-to Serial converter.
      FreeMASTER Lite
    • Host side operating system: Windows XP to through Windows 10 32/64bit or Linux 64bit.
    • Hard drive space: 470 MB (Windows) / 230 MB (Linux).
    • Required software: Java JRE (Linux).
    • Required hardware: Serial RS-232 port for local control or USB-to Serial converter.

Do you already meet the requirement?

Wish it helps you!

Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

162 Views
arunsharma
Contributor III

Hi kerryzhou
I have both FreeMaster 2.5 and FreeMASTER 3.0 installed on my laptop, but both are giving the same problem.

And yes my system meets the required requirement.

Can you please suggest, where should I debug to find out the problem?

0 Kudos

162 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi xpress-embedo,

  So, your probem is the Freemaster with your PC issue, not the kinetis MCU issue, please create a new freemaster question in this post:

FreeMASTER 

  Then the freemaster will help you to check it, when you create the question post, please also give your PC operation system.

   Thanks a lot for your understanding.

Wish it helps you!

Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos