Mk64 series uart problem using Processor expert.

cancel
Showing results for 
Search instead for 
Did you mean: 

Mk64 series uart problem using Processor expert.

184 Views
Contributor II

I have successfully configured my custom hardware using the processor expert to blink leds and use the uart functionality.

The processor expert generates code for internal clock of 32khz by default. My uart works fine with the baud rate of 9600.

Processor : MK64fn1m0vll12

Now I configure the external clock source using processor  expert for a clock of 20Mhz using clock source system oscillator 0.

The following are the clock values

Core clock : 8 Mhz

Bus Clock : 4 Mhz

External Bus clock : 4 Mhz

Flash Clock : 8 Mhz.

Clock Frequency : 48 Mhz.

Mcg Mode : PEE.

I generate code for the same and try to debug, but uart display garabage characters. I guess it is due to the clock settings 

I have changed . Kindly help me out with a solution to this problem. 

I am trying my best by reading the k64 reference manual and other forum answers related to the uart

Regards,

Sanket

Labels (1)
0 Kudos
3 Replies

20 Views
NXP TechSupport
NXP TechSupport

Hello Sanket,

Does the "Clock Frequency : 48 Mhz." is the clock frequency of System oscillator as below ?

pastedImage_1.png

If yes, the 48Mhz exceeds the range .

So could you please share your project , then we can know your configuration clearly .

BR

ALice

0 Kudos

20 Views
Contributor II

Hi Alice, 

Thank You for the reply.

There was a problem with the crystal, I guess was a faulty part.

Now the uart is working with both internal clock reference and external clock reference. 

I have a question related to Processor expert, when I change a single component and generate code

the other components code is also generated . I have three components gpio,uart and clock.

when i change clock settings in PE, code is generated for all three, whereas I want it to generate for only clock.

Can you kindly help me out with the uart example using interrupts.

Regards,

Sanket

0 Kudos

20 Views
NXP TechSupport
NXP TechSupport

Hello Sanket,

- There is uart transfer with interrupt demo under "Typical Usage":

pastedImage_1.png

- If you don't want some components generate code , please enable the "Don't Write Generated Component Modules":

pastedImage_2.png

Hope it helps


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------