Kinetis K10 Security

cancel
Showing results for 
Search instead for 
Did you mean: 

Kinetis K10 Security

145 Views
NXP Employee
NXP Employee

Hi,

  I have a customer who had an issue that after enabling security of the K10 120Mhz MCU, the code does not execute. After trying with flasher (the thunder symbol) the test project of just blinking an LED worked. But the main code of customer does not work when security is enabled. Also tried flashing it with cyclone max.. But same result. Why would it be that simple blinking code works but not the main code of the customer after enabling the security does not work... Pls help .. This is a bit urgent.

Thanks,

Amit Gombi.

0 Kudos
4 Replies

33 Views
NXP Employee
NXP Employee

Hi Amit,

Sounds like they might have corrupted something in the code. The continuous resets are most likely the core attempting to boot the code, then getting multiple faults leading to a core lockup reset. Just to double check...did they test their code with security disabled? 

When they enabled security what exactly did they do? Did they modify the flash configuration field values, then reprogram the entire image? If they just tried to update the flash configuration field, then that might be their problem. The Unsecure state is a value of 0xFE, so one bit is programmed. If you try to change 0xFE to another value that is secured, then you are overprogramming the flash which can corrupt the value. So the correct thing to do is erase and reprogram the entire image (or at minimum the entire first sector where the flash configuration field lives).

Hope this helps,

Melissa

0 Kudos

33 Views
NXP Employee
NXP Employee

Hi Melissa,

   Thanks for the inputs.. They do erase the whole chip and then flash the whole chip with new image with security bits enabled. If they do not change the security bits , then their code works correctly. Can you think of anything which can cause this issue?

Thanks,

Amit Gombi.

0 Kudos

33 Views
Senior Contributor II

I ran into something like that when I was first using the KL27.

Don't recall the exact details.  In general it was interaction between

the boot modes, FOPT and the security settings/ Backdoor Key.

0 Kudos

33 Views
NXP Employee
NXP Employee

hi,

   I also see that reset is toggling continuously..

0 Kudos