KV11 CAN Disable Receiving Transmitter Packets (echo)

cancel
Showing results for 
Search instead for 
Did you mean: 

KV11 CAN Disable Receiving Transmitter Packets (echo)

Jump to solution
622 Views
abdullah_cinar
Contributor III

Hi,

I am trying to send and receive CAN packets between my MKV11Z64 and a custom CAN device. I disabled ID filtering, so I am receiving every packet coming from the CAN line. But the problem is I also receive the packets that I transmitted. I just want to receive the packets sent from the other device.

I attached the file that contains my CAN configurations. The echo mode is already disabled by the way.

Labels (1)
0 Kudos
1 Solution
483 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi Abdullah,

Please check the value of CANx_MCR[SRXDIS]

CANx_MCR[SRXDIS].png

Best Regards,

Robin

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
484 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi Abdullah,

Please check the value of CANx_MCR[SRXDIS]

CANx_MCR[SRXDIS].png

Best Regards,

Robin

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
484 Views
abdullah_cinar
Contributor III

Hello Robin,

Thank you for your answer. I set the SRXDIS bit to 1 as you suggested. Below is the snippet for reference who finds this post. I needed to do it in FLEXCAN_Init() function in the fsl_flexcan.c file. Otherwise, it didn't work outside of this function.

mcrTemp |= (1 << 17); //disable self reception (CANx_MCR SRXDIS=1)
/* Save MCR Configuation. */
base->MCR = mcrTemp;

0 Kudos