KL25Z not showing up device manager

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

KL25Z not showing up device manager

Jump to solution
2,898 Views
lander
Contributor IV

Hello,

When I plugged in the board yesterday the FRDM-KL25Z driver showed up and the "OpenSDA - CDC Serial Port" was visual under Ports. I tried desperately to program the OpenSDA firmare by following the directions on this website, OpenSDA on the Freedom KL25Z Board | MCU on Eclipse but I still had no success. There was no green LED blink once I followed the BOOTLOADER directions and then taking away power and plugging it in again, resulting that under Jungo in my device manager, there was no PEMicro OpenSDA Debug Driver, only WinDriver.

Now, I'm facing the problem that the FRDM-KL25Z driver and the "OpenSDA - CDC Serial Port" no longer is popping up when I plug in my device. The device is still running it's demo with the RGB LED and such but the device is not being recognized.

I do not know why such a simple task is not working for me and I appreciate any advice.

Thank you.

0 Kudos
1 Solution
1,530 Views
lander
Contributor IV
0 Kudos
5 Replies
1,531 Views
lander
Contributor IV

https://community.freescale.com/message/314381#314381

This discussion helped with my issue.

0 Kudos
1,530 Views
BlackNight
NXP Employee
NXP Employee

Have you used the right USB port (the one labeled with 'SDA') which is nearby J8 (unpopulated SWD 10 pin header)?

If you plug it in there, the green small SMD LED turns on if OpenSDA is powered.

if it flashing, then no SDA application is loaded, and it should enumerate as BOOTLOADER.

I hope this helps.

0 Kudos
1,531 Views
lander
Contributor IV

It is plugged into the right USB port. After trying BOOTLOADER over and over and it not working the device now doesn't show up at all on my computer. "OpenSDA - CDC Serial Port" isn't showing up on my device manager either. I don't know what I did wrong!?

0 Kudos
1,531 Views
BlackNight
NXP Employee
NXP Employee

Can you try it with another PC?

If the green LED does not go on, and if it does not work on another machine, it could be that your board is broken. Or that the USB connector might have an issue.

Try as well a different USB cable as I had issues broken USB cables.

Otherwise: I'm running out of ideas.

0 Kudos
1,531 Views
lander
Contributor IV

I tried everything but plugging it into another PC, no luck. Thank you for your help!

0 Kudos