Java error in MCUxpresso IDE

cancel
Showing results for 
Search instead for 
Did you mean: 

Java error in MCUxpresso IDE

948 Views
Senior Contributor II

We're moving to MCUxpresso with our Kinetis-based products, and currently we have a project on our build server that is "failing" with the following Java error:

[15:48:59]Mcuxpressoidec:
[15:48:59]Java was started but returned exit code=1
[15:48:59]-Djava.class.path=C:\nxp\MCUXpressoIDE_10.2.1_795\ide\\plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
[15:48:59]-os win32
[15:48:59]-ws win32
[15:48:59]-arch x86
[15:48:59]-launcher C:\nxp\MCUXpressoIDE_10.2.1_795\ide\mcuxpressoidec.exe
[15:48:59]-name Mcuxpressoidec
[15:48:59]--launcher.library C:\nxp\MCUXpressoIDE_10.2.1_795\ide\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.551.v20171108-1834\eclipse_1630.dll
[15:48:59]-startup C:\nxp\MCUXpressoIDE_10.2.1_795\ide\\plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
[15:48:59]--launcher.overrideVmargs
[15:48:59]-application org.eclipse.cdt.managedbuilder.core.headlessbuild
[15:48:59]-data MCUX_VF1_Workspace
[15:48:59]-cleanBuild MCUX_VF1/Debug
[15:48:59]-import nxp\MCUX_VF1
[15:48:59]-vm C:\nxp\MCUXpressoIDE_10.2.1_795\ide\jre\bin\client\jvm.dll
[15:48:59]-vmargs
[15:48:59]-Djava.class.path=C:\nxp\MCUXpressoIDE_10.2.1_795\ide\\plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
[15:48:59]Process exited with code 1

The strange thing is that the code is still compiled and the binary is generated.

I've read in the Eclipse forums that in order to solve this problem, we have to match the "bitness" of the JDK and MCUxpresso.  I can't definitively find this information for MCUxpresso.  In the output above, I can't tell if -arch x86 refers to the JDK or the IDE.

Is anyone else having this problem?  We see it on our build server, but not on developer PCs.

Labels (1)
Tags (1)
0 Kudos
6 Replies

167 Views
Contributor I

Did you ever solve this problem? I'm currently having the same issue with MCUXpresso 11.2.0.

0 Kudos

182 Views
NXP Employee
NXP Employee

Hello,

I am sorry for the late response and not sure if the problem still exist or not. We had update the MCUXpresso to 10.3.0 and you can download it from:MCUXpresso IDE|Eclipse-based Integrated Development Environment (IDE)|NXP 

Make sure the host operating systems requirement:

  • Microsoft® Windows® 7/8/10
  • Ubuntu Linux® 16.04 LTS and later (64-bit host OS only)
  • Mac OS X 10.11 and later
0 Kudos

182 Views
Senior Contributor II

I'll add a helpful hint that hadn't even occurred to me -- run the IDE and then open Task Manager.  You'll be able to tell in the Processes tab if it's a 32 bit application.  In our case, it is 32 bit, so I'm going to try to install the 32 bit JRE to see if that helps.

0 Kudos

182 Views
Senior Contributor II

Switching to the 32 bit JRE made no difference.  I still get this error.

0 Kudos

182 Views
NXP Employee
NXP Employee

Hello,

Did you tried to un-install the MCUxpresso first then re-install it?

0 Kudos

182 Views
Senior Contributor II

No, as that seems like the least-likely way to solve this problem.  Can you explain why reinstalling MCUXpresso might work?  Installing/upgrading to the latest version didn't make the problem go away.

0 Kudos