FRDM-K82F installing Segger OpenSDAv2.1

cancel
Showing results for 
Search instead for 
Did you mean: 

FRDM-K82F installing Segger OpenSDAv2.1

Jump to solution
488 Views
cconlon
Contributor II

Hi,

I am trying to install the Segger OpenSDAv2.1 firmware on a FRDM-K82F platform.  I'm having an issue getting the board to mount in BOOTLOADER mode, after holding down the reset button and plugging in the board.  These are the steps I am doing:

  1. Plug USB cable into "SDA-USB" port
  2. Hold down "Reset" button
  3. Plug the board into development machine

The results after doing this are that the board mounts as "MBED", not "BOOTLOADER".  I am working on a Windows 7 Pro VM, with the most current Segger J-Link software, KDS, and KDS Add-On for the FRDM-K82F.  Any ideas of what I might be doing wrong?

Thanks,

Chris

0 Kudos
1 Solution
111 Views
anthony_huereca
NXP Employee
NXP Employee

Hi Chris,

Make sure jumper J23 is on pins 1-2. On some early versions of the board this was incorrectly installed on pins 2-3 instead.

-Anthony

View solution in original post

0 Kudos
4 Replies
111 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Chris,

Please do as these steps:

1.Press and hold the Reset button,

2.Plug in a USB cable (not included) between a USB host(PC) and the OpenSDAv2 USB connector (labeled “SDA”)

3.Release the Reset button


Have a great day,
Alice Yang

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
111 Views
cconlon
Contributor II

Hi Alice,

Thanks for the reply. When I try the steps you listed, my FRDM-K82F board mounts in Windows as "MBED (E:)" instead of "BOOTLOADER" as the documentation states it should.

Thanks,

Chris

0 Kudos
112 Views
anthony_huereca
NXP Employee
NXP Employee

Hi Chris,

Make sure jumper J23 is on pins 1-2. On some early versions of the board this was incorrectly installed on pins 2-3 instead.

-Anthony

View solution in original post

0 Kudos
111 Views
cconlon
Contributor II

Hi Anthony,

Good catch!  That was the problem.  J23 was on pins 2-3 for the board I had on hand.

Thanks,

Chris

0 Kudos