FRDM K64F 16-bit SPI issue

cancel
Showing results for 
Search instead for 
Did you mean: 

FRDM K64F 16-bit SPI issue

Jump to solution
288 Views
bastienchatton
Contributor I

Hello!

I am currently trying to communicate with a 16-bit SPI device (MEMSIC MXP7205VF) using my FRDM K64F.

I am using SPIMaster from Processor Expert. For some reason when I set the width to 16-bit, the clock always stays low!

With 8-bit the clock ticks normally...

Can someone explain this? Thank you for your help :smileyhappy:

SPIMaster.PNG

Labels (1)
Tags (3)
0 Kudos
1 Solution
149 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi Bastien,

The issue seems weird, and I was wondering if you can share the demo, then I run the demo on the FRDM-K64F board to reproduce the issue.

I'm looking forward to your apply.
Have a great day,
Ping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
150 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi Bastien,

The issue seems weird, and I was wondering if you can share the demo, then I run the demo on the FRDM-K64F board to reproduce the issue.

I'm looking forward to your apply.
Have a great day,
Ping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
149 Views
bastienchatton
Contributor I

Indeed, my bad! I don't know where it went wrong but everything is working fine now.

Thank you for having taken time to answer!

Regards

Bastien

0 Kudos