The project does not appear in the Debug configurations

cancel
Showing results for 
Search instead for 
Did you mean: 

The project does not appear in the Debug configurations

262 Views
pietrodicastri
Senior Contributor I

Good morning

 

I have a strange problem with the KDS 3.2.0

I produced a project. It  builds correctly but it is not possible to debug, since it does not appear in the list in the Debug configurations. It is visible in the attached files.

 

If there is a good advice it could be easy to fix 

 

 

Thank You

Labels (1)
Tags (1)
8 Replies

104 Views
pietrodicastri
Senior Contributor I

Ok ..

I have recreated the project from the scrap. It is now running. 

Definitely I think I put the KDS in unusual situation .. Who knows..

Thank You

0 Kudos

104 Views
pietrodicastri
Senior Contributor I

Thank you for the help..

I try whatever but I don t get it to work.. Something I did has now put in an inconsistent state. I will try to recreate the project.

0 Kudos

104 Views
BlackNight
NXP Employee
NXP Employee

Are .launch files present in your project?

0 Kudos

104 Views
pietrodicastri
Senior Contributor I

Hi Erich

The project Encoder003 does not appear in the list. It is an executable, actually identical to the Encoder002. For a reason I don t understand it is not possible to debug.. 

Thank You

0 Kudos

104 Views
pietrodicastri
Senior Contributor I

Effectively at a closer look also the Encoder002 project is not in the list. I used some time ago for debugging without any problem. Maybe the migration from a KDS  older version has created a problem???

Thank You

0 Kudos

104 Views
BlackNight
NXP Employee
NXP Employee

check your filters (see my answer above).

And check if the Encoder projects have .launch files in it.

Erich

0 Kudos

104 Views
BlackNight
NXP Employee
NXP Employee

Hi Pietro,

that dialig lists all the .launch files inside your projects, if they reference a project, plus the ones stored in the 'framework' (if not shared as file, see Sharing Debug Configuration with Eclipse | MCU on Eclipse ). Then they are filtered too. So could it be that you have it filtered, so can you check your filters?

pastedImage_377.png

I hope this helps,

Erich

104 Views
BlackNight
NXP Employee
NXP Employee

Hi Pietro,

which project?

If it is it the lib (library) project: you won't be able to debug a library project directly: you debug the project which is using the library.

I hope this helps,

Erich

0 Kudos