OPENSDA on FRDM KW40Z failed

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

OPENSDA on FRDM KW40Z failed

1,063 Views
eliar
Contributor II

Hi

 

I compiled hello world on the reference design.

Added   -f kinetis.cfg  in the option to let opensda server use this config file

but i am still  getting this error:

Open On-Chip Debugger 0.8.0-dev (2015-01-09-16:22)

Licensed under GNU GPL v2

For bug reports, read

  http://openocd.sourceforge.net/doc/doxygen/bugs.html

Info : only one transport option; autoselect 'cmsis-dap'

Error: unable to open CMSIS-DAP device

Error: unable to init CMSIS-DAP driver

Error: Error selecting 'cmsis-dap' as transport

Runtime Error: C:/Freescale/KDS_v3/openocd/bin/..//scripts/kinetis.cfg:3:

in procedure 'script'

at file "embedded:startup.tcl", line 58

in procedure 'interface' called at file "C:/Freescale/KDS_v3/openocd/bin/..//scripts/kinetis.cfg", line 3

 

I read some where that it is related to bad firmware. i want to use the on chip opensda  in the kw40z reference design

just for burning new firmware every time, speed is not important.

 

i could not find any solution to this error.

is this bug can be solved?  or we must buy jlink to burn firmware?

 

Thanks.!

Labels (1)
0 Kudos
9 Replies

641 Views
lokuate
Contributor III

OK, but how do you debug your application once dragged-and-dropped?

Carlos

0 Kudos

641 Views
eliar
Contributor II

1.PNG2.PNG3.PNG4.PNG

0 Kudos

641 Views
eliar
Contributor II

Hi

After following this page instructions:

http://www.nxp.com/products/software-and-tools/run-time-software/kinetis-software-and-tools/ides-for...

I copy the bin file which i downloaded into the bootloader folder when it opened.

But immediately after the copy finished , the DAP link folder opened.

So to unplug and plug again does not seems to help.

also, the boot loader bin file is not there when i  boot again (with reset pressed)

In addition , i installed the mbed serial driver to get ready to UART debug print from:

Terminals - Handbook | mbed

There is no MBED disk name

Kinetis Studio does not able to connect OPENOCD server to download and debug

nothing seems to work.

0 Kudos

641 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Eli,

Could you please take a screenshot about the steps you operate , from how do you update the bootloader.

Then i check your operate and the phenomenon to check the problem .

BR

Alice

0 Kudos

641 Views
eliar
Contributor II

Hi

I Solved it.

Just to help everyone that want a jump start:

NXP FRM boards have two bootloaders , mbed and opensda.

The FRDM boards comes with mbed bootloaders and in order to work with mbed bootloader in kinetis design studio

The files needs to be bin file ( row binary)

So in order to generate SREC->BIN follow this article here:

https://mcuoneclipse.com/2014/04/20/binary-files-for-the-mbed-bootloader-with-eclipse-and-gnu-arm-ec...

once you have bin file, you can start drag and drop it into your FRDM 40Z device for example

Eli

0 Kudos

641 Views
eliar
Contributor II

Alice

I download the driver for the serial port from this location

http://www.nxp.com/products/software-and-tools/hardware-development-tools/freedom-development-boards...

and now I am seeing some connectivity and this message

I am not able to run it from kinetis IDE

Or download the elf.

What should I do now , the video in the web site is for IAR

Open On-Chip Debugger 0.8.0-dev (2015-01-09-16:22)

Licensed under GNU GPL v2

For bug reports, read

http://openocd.sourceforge.net/doc/doxygen/bugs.html

Info : only one transport option; autoselect 'cmsis-dap'

Info : CMSIS-DAP: SWD Supported

Info : CMSIS-DAP: Interface Initialised (SWD)

Info : add flash_bank kinetis kinetis.flash

cortex_m reset_config sysresetreq

adapter speed: 1000 kHz

Started by GNU ARM Eclipse

Info : CMSIS-DAP: FW Version = 1.0

Info : SWCLK/TCK = 0 SWDIO/TMS = 1 TDI = 0 TDO = 0 nTRST = 0 nRESET = 1

Info : DAP_SWJ Sequence (reset: 50+ '1' followed by 0)

Info : CMSIS-DAP: Interface ready

Info : clock speed 1000 kHz

Info : IDCODE 0x0bc11477

Info : kinetis.cpu: hardware has 2 breakpoints, 2 watchpoints

Info : accepting 'gdb' connection from 3333

Error: MCU is unsupported

Error: auto_probe failed

Error: Connect failed. Consider setting up a gdb-attach event for the target to prepare target for GDB connect, or use 'gdb_memory_map disable'.

Error: attempted 'gdb' connection rejected

0 Kudos

641 Views
eliar
Contributor II

Hi Alice,

I tried to download , just drag and drop the file

i2c_rtos_bm_slave_frdmkw40z.elf

which is on disk , a 300kb size, and it failed.

Is it correct to download this 300kb elf file?

The total size of the 40z is 160kb flash only

This is why it failed, right?

But the code is so initial code, nothing much there.

Please assist,

Thanks

Eli

0 Kudos

641 Views
eliar
Contributor II

I did that

Can you read mail from here

0 Kudos

641 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Eli,

Please  copy one of the openSDA firmware into your board when the board in bootloader mode.

you can download the firmware at here :

OpenSDA Serial and Debug Adapter|NXP

pastedImage_1.png

if you choose the first two, when you debug ,please select

pastedImage_2.png

of you copy the last one , please select jlink :

pastedImage_3.png

If still can not connect, please take screenshot about the steps one by one show me how do you operate.

Hope it helps

ALice

0 Kudos