GNU not compatible with KDS?

cancel
Showing results for 
Search instead for 
Did you mean: 

GNU not compatible with KDS?

140 Views
laudexter
Contributor I

I was working on a BLE project just fine with KDS, when one day, the debugger seemed to start throwing problems. The error message: "Error in final launch sequence. Failed to execute MI command" would turn up whenever I tried to debug, even on previously working projects. 

I checked the changes I made to my computer, and uninstalled a few programs. It was only after uninstalling the program: 

GNU toolchain for ARM Cortex-M and Cortex-R processors

that my KDS started to work again.

Can I check why does GNU interfere with KDS?

0 Kudos
1 Reply

83 Views
BlackNight
NXP Employee
NXP Employee

I think you had a problem with your launch configuration (and not with GNU itself), maybe you configured something in there in a wrong way? Usually that message indicates that the Eclipse GDB client cannot communicate with the GDB server. The error message might depend on the situation, see GDB Client and Server: Unlocking GDB | MCU on Eclipse.

A reason could be that you had a dangling GDB server executable around.

As a side effect of uinstalling/installing things you problably solved that problem.

I hope this helps,

Erich