Flashing Problems in KDS 3.2

cancel
Showing results for 
Search instead for 
Did you mean: 

Flashing Problems in KDS 3.2

465 Views
vigneshbalaji
Senior Contributor I

Hi,

    I am using KDS3.2. I used a project in a different system it is working well.But When I use it in this system then It shows me Errors like Connection Closed by GDB Server, Failed to execute MI command etc150233_150233.pngScreenshot (6).png150234_150234.pngScreenshot (5).png150235_150235.pngScreenshot (4).png

Labels (1)
5 Replies

79 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello ,

I think the project of "sfs" is i send to you , i can download and debug it well on TRK-KEA128 board.

1) Please be sure the firmware of your board  from the computer management, does it j-link ?

take a screenshot about this to me :

pastedImage_0.png

2) Disable all of the breakpoints in your project before download.

3) You can also take a screenshot about the steps when you download .

Hope it helps

Alice

79 Views
vigneshbalaji
Senior Contributor I

Please take up this question on the new thread Flashing Problems in KDS 3.2?

0 Kudos

79 Views
vigneshbalaji
Senior Contributor I

Hi Alice,

             I suspect The computer because I did things from other computer and same TRK-KEA128 Board it worked.

And Initially I tried with open SDA. I saw The Open SDA in Device Manager Also.

While Trying with Open SDA The Flashing Took very much longer that I have to cancel it, I have attached the Screenshot  of it in pic 1.Then Second Time it throwed an error for which also I have attached a Screenshot in pic 2.

Screenshot (4).pngScreenshot (2).png

I want to know the exact problem behind this and to solve it.

0 Kudos

79 Views
vigneshbalaji
Senior Contributor I

I am getting a Debugger settings like this the port is not selected.Screenshot (31).png

I have attached the Project on the new thread below.Screenshot (18).png

0 Kudos

79 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello,

When you use the Open SDA to debug , please configure the debugger as this :

pastedImage_0.png

Hope it helps

Alice

0 Kudos