Error loading programming algorithm

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error loading programming algorithm

Contributor I

Hello, We are using Multilink Universal FX (0585536309) JTag, with Kinetis environment, on Freescale MK22FN512VLH12 MCU. We used K22FN512xxx12_flash.ld linker file, and it worked properly. Then, trying to avoid burning to flash, we tried to load our software to the RAM using K22FN512xxx12_ram.ld linker file, and changed some details such as __heap_size__ and __stack_size__ trying to make it work, we apparently screwed up the Boot loader or something. Now, trying to burn to the flash and debug the software as before, we get the output: Loading programming algorithm ... Error loading .ARP file : C:\Freescale\KDS_1.1.1\eclipse\plugins\com.pemicro.debug.gdbjtag.pne_1.1.6.201409261701\win32\gdi\P&E\freescale_k22fn512m12_1x32x128k_pflash.arp at address 20000000 Error loading programming algorithm - load aborted. Error occured during Flash programming. PE-ERROR: Error downloading to the device. What can be done to fix this problem? Thanks

0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport


We need make several test to identify where is the problem.

1. identify the problem on board side or computer side : create a NEW workspace and NEW project on another computer, test how it works.

2. KDS1.1 is too old, use KDS3.2 instead. here is KDS3.2

Kinetis® Design Studio Integrated Development Environment (IDE)|NXP 

3. Other possible reason is that your chip is damaged, for example see this thread

.ARP File Error 

Have a great day,
Jennie Zhang

Note: If this post answers your question, please click the Correct Answer button. Thank you!

0 Kudos