ZLG communication problem

cancel
Showing results for 
Search instead for 
Did you mean: 

ZLG communication problem

Jump to solution
267 Views
Contributor IV

Hi,

    The freemaster fails to communicate with ZLG device in my computer,the ZLG device is USBCAN-II and the freemaster version is 3.0.I think my ControlCAN.dll is not the right one.Please share me a ControlCAN.dll file,which helps communication between ZLG device and freemaster .Thanks!

pastedImage_1.png

pastedImage_2.png

pastedImage_3.png

0 Kudos
1 Solution
82 Views
NXP Employee
NXP Employee

Thanks for feedback. This new CAN plug-in version is going to be included in the upcoming 3.0.3 update.

Regards,

Michal

View solution in original post

0 Kudos
7 Replies
82 Views
NXP Employee
NXP Employee

Hello, can you please confirm that your ZLG CAN device can be accessed using the original CANtest software provided by ZLG

I have tested the FreeMASTER-ZLG compatibility using the DLL from CANtest v2.41. I'm going to re-test using the latest 2.70.

Thanks,

Michal 

0 Kudos
82 Views
Contributor IV

Hi,

 Thanks for your reply!Now I open two channels in the USBCAN-II,a channel for sending messages and the other for receiving messages.It shows my ZLG CAN device works well.

pastedImage_1.png

pastedImage_2.png

Best regards!

0 Kudos
82 Views
NXP Employee
NXP Employee

Hello,

I confirm that my ZLG USBCAN2 test device is also not visible, the USBCAN_2E_U device works well. 

In my case, I'm facing issues also with USBCAN2 Windows low-level driver - the device is not visible even in the CANtest so I'm not even able to test my new plugin build physically. I will try to resolve the issue as soon as possible. Anyway, I'm attaching a FreeMASTER CAN plug-in rebuilt with the latest ZLG libraries. Can you please try it on your side? Just replace the file in "c:\NXP\FreeMASTER 3.0\FreeMASTER\plugins\can" folder.

Thank you,

Michal

0 Kudos
82 Views
Contributor IV

Hi,

I test it again and the ZLG USBCAN2 is still not visible.The result is  as  picture below shown.

pastedImage_1.png

Best regards!

HJ

0 Kudos
82 Views
NXP Employee
NXP Employee

Hello, 

I have been finally able to test this new plugin DLL with USBCAN2 device and it works well on my side. Can you make sure you have copied the DLL to the right place and that you do not have multiple FreeMASTER versions.

In case you have multiple FreeMASTER versions installed, I recommend to re-install the 3.0.2 version and copy the attached DLL to installation folder that was used for this last installation.

The properties of the DLL should show version 1.8.0.0

pastedImage_1.png

Regards,

Michal

0 Kudos
82 Views
Contributor IV

Hi,

I re-install freemaster 3.0 and then replace the "focpgi.dll" in "c:\NXP\FreeMASTER 3.0\FreeMASTER\plugins\can" folder.To my surprise,it does work.Thanks very much for your help!

pastedImage_1.png

0 Kudos
83 Views
NXP Employee
NXP Employee

Thanks for feedback. This new CAN plug-in version is going to be included in the upcoming 3.0.3 update.

Regards,

Michal

View solution in original post

0 Kudos