Freemaster not getting connected

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Freemaster not getting connected

1,686 Views
AjRj14
Contributor III

Hi,

I am new to freemaster.

I am tying to visualise  variable in freemaster as specified in the video in below link:

https://community.nxp.com/t5/Model-Based-Design-Toolbox-MBDT/Module-1-Environment-Setup/m-p/734725

 

But I am getting the below error.

AjRj14_0-1647886021979.png

 

Could you please help to resolve this issue.

0 Kudos
5 Replies

1,670 Views
MichalH
NXP Apps Support
NXP Apps Support

Hello,

this kind of error is typical when you try to use an invalid COM port to connect to your target application. You can try to use a Connection Wizard by clicking at its icon in the main page or by using menu Tools/Connection Wizard.

Please describe your connection line between the PC and target application in more details.

Thanks,
Michal

0 Kudos

1,655 Views
AjRj14
Contributor III

Hi,

I am using s32k144 dev kit. The kit is connected to my laptop through the USB .

I am trying to access a variable in Freemaster. But the Freemaster is not getting connected with dev kit.

I tried using connection wizard but the below error is showing.

 

AjRj14_0-1648052609453.png

 

0 Kudos

1,646 Views
MichalH
NXP Apps Support
NXP Apps Support

Hello,

do you have this S32K144-EVK board? Do you have the jumpers set the same way as in the photo at this page? 

As soon as you connect the USB cable, your Windows system should detect the COM port. You can check your Windows Settings / Bluetooth & Other devices - you should see the OpenSDA Hardware in the devices list. Also, when you connect the board, a virtual disk drive (D: or alike) should appear with LASTSTAT.TXT file - and when you open it, it should say "Ready."

If not, it is possible that your board is damaged or maybe there is an old firmware, missing Windows drivers or some other reason. Please tell if you can use the board with the S32 Design Studio to compile and flash a code in the board.

When properly connected, the FreeMASTER Connection Wizard should be able to find the OpenSDA COM port like in my case:

MichalH_0-1648066877778.png

Regards,
Michal

 

0 Kudos

1,627 Views
AjRj14
Contributor III

Thanks Michal for the reply,

1). The jumpers are connected as in the image

2). In device list, the OPEN SDA HARDWARE looks like below:

AjRj14_0-1648144975347.png

Do I need to install any driver software apart from FREEMASTER?

3). A virtual disk drive is appearing with LASTSTAT.TXT file - and when I open it, it  says "Ready."

4).Crrently I am generating code from MATLAB and dumping the code to the board directly from MATLAB and the code is executing its job perfectly.

 

Could you please confirm whether the issue is with board or the wauy in which I installed FREEMASTER?

 

Thanks in Advance.

0 Kudos

1,614 Views
MichalH
NXP Apps Support
NXP Apps Support

I think you are missing a OpenSDA driver for the virtual serial port (CDC) device implemented by the OpenSDA interface. Can you please double check the Device Manager in the Computer Management console (locate "This PC" icon on desktop, pull the context menu and select "Manage...") 

You should see the OpenSDA-CDC and a COM number assigned to it (COM36 in my case shown in the picture).

If not, re-installing the pemicro drivers could help.

Regards,
Michal

MichalH_1-1648206112060.png

 

 

0 Kudos