I cannot debug a new program on mc56f84789X?

cancel
Showing results for 
Search instead for 
Did you mean: 

I cannot debug a new program on mc56f84789X?

898 Views
lucasspadini
Contributor I

I was using a TWR-56f8400 and it stopped working. Now I cannot download a new program in it. The USB driver recognizes the board, but i cannot debug  a new program. I get the following message when i try to debug my program.

 

154225_154225.pngUntitled.png

Is there a routine for checking if my DSC is still properly working? How can I fix it ?

Labels (1)
Tags (2)
0 Kudos
2 Replies

555 Views
TICS_Fiona
NXP Employee
NXP Employee

Hello Lucas

When using OSJTAG for debugging, please install the jumpers on J20 and J21.

If power supplied through PWR_IN power net at J3, please connect shunts J6-1 to J7-2, and connect J10-1 to J11-2, remove the jumper on J20.

If powered supplied through Mini-B USB connector at J18, please connect shunts J11-1 to J11-2, and shunts J6-1 to J7-2, and also remove the jumper on J20.

For details, please review the TWR-56f8400 board’s user manual.

And please check the device manager, whether the driver for OSJTAG is installed successfully?  If not, please reinstall the driver.

Best Regards

Fiona Kuang

TIC - Technical Information Center

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Mark Correct button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

555 Views
johnlwinters
NXP Employee
NXP Employee

There are three likely causes, one of which may be the issue:

1) Your project or workarea or computer has become corrupted.

2) You have programmed the JTAG pins to be GPIO

3) Static electricity has damaged the JTAG port of other part of the device

Try installing the tools on a fresh computer, for one.

If a fresh computer is not available, try to restore your computer and reinstall the tools.

If that does not work, then, for three, it might be advisable to also get a new board.

Number two above is unlikely, and you would probably know if you did that. But it would also be solved by getting the new board.

0 Kudos