SPI/UART - Bridge demo: Problems with connection to the SPI-port

cancel
Showing results for 
Search instead for 
Did you mean: 

SPI/UART - Bridge demo: Problems with connection to the SPI-port

399 Views
admin
Specialist II

Hey mates!

 

I am currently trying to get the UART/SPI-bridge example programm working.

 

The M51CN128EVB.h defines the following line:

#define UART_PORT          1/*Second Port*/

 

I made the following settings in the constants.c:

    /*FSL:smileyfrustrated:PI options*/
    SPI_PORT,                      /*spi port*/
    BAUD_1000,                   /*spi baudrate*/
    0,                                        /*idle high*/
    0,                                        /*middle sample*/
    0,                                        /*spi slave mode*/
    0,                                        /*polling*/
    0,                                        /*don't care*/

 

My questions are: Why is number one the second port? Where can I find the SPI-Ports on my TWR-MCF51CN (yes I searched many hours in the documentation)?

 

Best regards and thank you in advance,

Camillo

 

/edit

Funny.... I have been searching for hours and shortly after my post I found the right document (http://cache.freescale.com/files/microcontrollers/hardware_tools/schematics/TWR-MCF51CN-SCH.pdf?fsrc...)

But there is still a question: Did anyone ever successfully tested the demo?

Labels (1)
0 Kudos
3 Replies

34 Views
chary
Contributor I

Hi,

I have worked on MCF51CN128 couple of months ago , I have developed SPI to Ethernet bridge using the software AN3906 successfully.

I am unable to understand your query , since the controller has only 80 pins the pins should be multiplexed with with different functions the reason for providing same SPI pins on different port pins they are just redundant you can use any of them. revert back to me if you have any other questions.

Regards,

Chary

0 Kudos

34 Views
admin
Specialist II

There comes another question.....

As I already mentioned, I figured out, that the SPIx signals are on the main port (backside of pci on the primary elevator), but..... why are there several MOSI0, etc, ports? Which pins have been muxed by the example? 

Thanks in advance

Camillo

0 Kudos

34 Views
admin
Specialist II

/push

0 Kudos