Target Process does not show Cortex-a53

cancel
Showing results for 
Search instead for 
Did you mean: 

Target Process does not show Cortex-a53

Jump to solution
163 Views
Contributor I

I am trying to select a target processor in CodeWarrior 11.4.0 and the Cortex-a53 does not show up in the drop down list. How do I select this processor?

0 Kudos
1 Solution
15 Views
NXP TechSupport
NXP TechSupport

CodeWarrior has removed support for customizing target-specific compiler optimizations, due to no perceived benefit in doing so.
You can still do that, though. Go to C/C++ Build -> Settings -> Tool Settings -> Cross ARM C Compiler -> Optimizations -> Other optimization flags and add "-mtune=cortex-a53" to that text box. Then recompile the project.

Have a great day,
Pavel Chubakov

View solution in original post

0 Kudos
3 Replies
16 Views
NXP TechSupport
NXP TechSupport

CodeWarrior has removed support for customizing target-specific compiler optimizations, due to no perceived benefit in doing so.
You can still do that, though. Go to C/C++ Build -> Settings -> Tool Settings -> Cross ARM C Compiler -> Optimizations -> Other optimization flags and add "-mtune=cortex-a53" to that text box. Then recompile the project.

Have a great day,
Pavel Chubakov

View solution in original post

0 Kudos
15 Views
NXP TechSupport
NXP TechSupport

See the following document about CodeWarrior 11.4.0:

https://www.nxp.com/docs/en/release-note/CW-ARMV8-RN.pdf

 

This CodeWarrior supports QorIQ LS-Series processors.

See the LS1012a, LS1043a and LS1088a Reference Manual.

These Reference Manuals shows that cores of these processors are Cortex A53.

Have a great day,
Pavel Chubakov

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
15 Views
Contributor I

That wasn't my question. I am using the LS1043a processor and want to select the cortex-a53 from the drop down menu from Properties->C/C++ Build->Settings->Tool Settings->Target Processor->Arm Family. Setting this adds -mcpu to the compiler command line, but Cortex-A15 is the highest core that can be selected. For now I am getting around this by selecting "Toolchain default" as the ARM family, and "armv8-a" as the Architecture.

0 Kudos