Codwarrion and flexlm

cancel
Showing results for 
Search instead for 
Did you mean: 

Codwarrion and flexlm

4,325 Views
Contributor I
I am using codewarrior 3.2 for the coldfire/68K architecture (I know its very old but we can't upgrade yet, its a long story). Anyway, I just installed it on a new system and copied my license file to the codewarrior directory. Codewarrior loads just fine but when I got to run the compiler it comes up with a message saying:

Error : Unable to use the plugin "Metrowerks C/C++". It is licensed and a valid license key was not found.
No such feature exists
Feature: Win32_Plugins_M68K
License path: C:\OrCAD\orcad_v105.dat;C:\Program Files\Metrowerks\CodeWarrior -
\license.dat
FLEXlm error: -5,357. System Error: 11001 "(null)"
For further information, refer to the FLEXlm End User Manual,
available at "www.globetrotter.com".

I have watched my firewall and it doesn't seem that it is even trying to connect to my license server. I have used lmutil manually and have verified that the license server is up and running. Please help!

Thanks,
Matt
Labels (1)
0 Kudos
7 Replies

98 Views
Specialist III

Hello

I assume you have asked Freescale licensing to migrate your license to a new Host PC.

Did you specify you are using CodeWarrior V3.2 when you requested the new license file.
If you have a V6.x or V5.x license file, it will not work with V3.2 software.

To check if your license is a V3.2 license:
    - Open the file in an edit window
    - You have a line starting with "FEATURE Win32_ColdFire_Compiler metrowks"
 The version number specified after metrowks must be 3.0.

Is that correct? If not, send an email to license@freescale.com, attach your current (non working) license file and tell them you NEED a CodeWarrior for Coldfire V3.2  license file.

I hope this helps.

CrasyCat

0 Kudos

98 Views
Contributor I
I forgot to mention that we are using floating licenses with a license server. I just took the license file from a working computer, shouldn't that be enough to get it connected and borrowing licenses correctly? The only other difference about this computer is that it used to have Codewarrior for the DSP56800E v7.3 installed. That has been removed but my problem still exists.

Matt
0 Kudos

98 Views
Specialist III

Hello

OK if you are using a floating license, you do not need to ask for a new license then.

Are you using the same server for DSP & Coldfire licenses? If this is the case you have to stop the FLEXlm Service, merge the two licenses and start the service again.

Any way to investigate that I would recommend you to send an email to license@freescale.com indicating you cannot build. Please attach the client and server license file you are using as well as the log file from the license server.

CrasyCat

0 Kudos

98 Views
Contributor I
I noticed last night that my codewarrior install is trying to get a license for a feature called

Win32_CWIDE_Limited

and my license file "feature" field says

Win32_CWIDE_Unlimited

Do you think thats part of the problem? If so how do I correct it? It looks to me like the client may be trying to look for some sort of evaluation license while my licenses are for the full blown product.

Matt
0 Kudos

98 Views
Specialist III

Hello

If it is around an issue to start the IDE, try to put the following line on top of your
CodeWarrior for Coldfire V3.2 client license file.

FEATURE Win32_CWIDE_Unlimited metrowks 4.2 permanent uncounted \
        D8C287BC5B1B HOSTID=ANY

CrasyCat

0 Kudos

98 Views
Contributor I
The issue isn't starting the IDE, its running the 68K compiler once the IDE is already running.

Matt
0 Kudos

98 Views
Specialist III

Hello

In that case, can you please submit a service request though our on-line support site.

Please attach your client & server license file as well as the log file from the server and the exact message you are doing.

Our support team will be able to help you then. 

CrasyCat

0 Kudos