CodeWarrior eMMC Flash bug

cancel
Showing results for 
Search instead for 
Did you mean: 

CodeWarrior eMMC Flash bug

118 Views
Contributor I

Hey,

We use Codewarrior for bring up our custom boards with ls1046ardb processors. We use the flash programmer tool extensively for programming eMMC devices. We have a specific version of the CodWarrior packages which works perfectly in an environment. We wanted to migrate this environment to another computer to be able to develop and flash the boards. We cannot reproduce our working environment because we have an issue with eMMC programming in all versions of codewarrior.

Problem description:

We start an eMMC operation (eg.: Blank Check, Erase etc.) and the led starts blinking and the Flash Programmer tool never returns. If I stop the Flash Programmer the CCS is still active in the background and the LEDs keep blinking.

I tried CodeWarrior 2018.1 with and without updates. Codewarrior 2019.1 with updates etc. Non of them are working. I share with you our working eclipse plugin set. I have no idea which plugin is responsible for this issue. I hope you will be able to solve this problem because we really need the migration of this environment.

We find a temporal solution to hardcopy the complete environment and use it on the new computer but that is not a real installation.

Our working CW plugin list in the attachment below

thank you

Dávid Huber

Tags (3)
0 Kudos
1 Reply

24 Views
NXP TechSupport
NXP TechSupport

Hello Dávid Huber,

Please try the latest version CodeWarrior 11.4.2.

Please install CodeWarrior for ARMv8 11.4.0, then update to CodeWarrior for ARMv8 11.4.2.

Please download and install CodeWarrior for ARMv8 11.4.0 from the following link.

https://drive.google.com/open?id=1OM6s-m4qKSjtF3iPg-P5eTbQVhPweaNj 

Please down CodeWarrior 11.4.2 installation package from the following link, then install CodeWarrior for ARMv8 11.4.2 from Help->Install New Software->Add->Archive.

https://drive.google.com/open?id=1B1XfDM51izCQCKHnp7pWQ5ic_joACzqJ

According to your attached plugin list, it seems that you are using CodeWarrior for ARMv8 11.3.3.

Please install CodeWarrior for ARMv8 2018.01(11.3.0), then download CodeWarrior for ARMv8 11.3.3 installation package from the following link, then install CodeWarrior for ARMv8 11.3.3 package from Help->Install New Software->Add->Archive.

https://drive.google.com/open?id=1aIzWB42B3PY12ufz9B_b9xyAzwAO6JcY 

Thanks,

Yiping

0 Kudos