Ignore interrupts when stepping the debugger

cancel
Showing results for 
Search instead for 
Did you mean: 

Ignore interrupts when stepping the debugger

851 Views
twp
Contributor III

Using CW 10.5 is it possible to configure the debugger to ignore interrupts while stepping?  I see this is possible using the classic IDE from the following post:

 

https://community.freescale.com/message/307587#307587

Labels (1)
0 Kudos
6 Replies

259 Views
stanish
NXP Employee
NXP Employee

Hi Twp,

Unfortunately there is no option to disable interrupts when stepping available in CW MCUs v10.5 for e200. This request has been already logged a feature request under the number ENGR00229357.

You can e.g. manually control EE bit in MSR register in the Register View to enable/disable interrupts as a workaround.

CW10_5_Register_View_Disable_Enable_External_interrrupts.png

If you need the interrupt handlers running on the background while stepping you can use "Run To Line" (Ctrl+R) and manually move line (cursor) at next code line as a workaround

Hope it helps.

Stan

0 Kudos

259 Views
BlackNight
NXP Employee
NXP Employee

Yes, it is there since MCU10.2 (MCU10.2 is here! Or: 4 t-shirts in 13 weeks… | MCU on Eclipse):

see attached screenshot: it is in the debug/launch configuration under 'interrupts'.

0 Kudos

259 Views
twp
Contributor III

That's where I would expect it to be, but I don't have that tab:no_interrupt_tab.png

Is this due to using a PnE MultiLink or is this due to the processor type MPC5643L?

0 Kudos

259 Views
BlackNight
NXP Employee
NXP Employee

That setting is specific to each architecture. Looks like it is not implemented for PowerPC.

0 Kudos

259 Views
twp
Contributor III

Any suggestions for a work around?  It makes it very difficult to debug without that setting as the thread stack looses the last code position when jumping in to an interrupt, Codewarrior also seems to close the file containing the code at the deepest point of the call stack.

0 Kudos

259 Views
BlackNight
NXP Employee
NXP Employee

I'm sorry, I'm not using PowerPC, and do not have a workaround. Only that you might disable the interrupts with a script (Debugger shell) maybe?

0 Kudos