CodeWarrior 8- & 16-bit tools: Flash programmer problem

cancel
Showing results for 
Search instead for 
Did you mean: 

CodeWarrior 8- & 16-bit tools: Flash programmer problem

1,381 Views
marc_paquette
Contributor V

To help you find solutions to problems that have already been solved, we have posted this message. It contains an entire topic ported from a separate forum. The original message and all replies are in this single message.

 

AKULKARNI308
Posted: Jun 13, 2005 - 08:18 AM   

i have made a board using MCF5407, 4Mbytes of SDRAM and 2Mbytes of Flash. I have customised the TRD project to suit my board. When I click the option of Flash Programming->Connect.. it connects. But when I try any of the below options like Blank Check, Program Flash, Erase etc I get the following error :
"CFP:Target Blank Check has timed out. Please check target board and connection settings and try again"

this error is for blank check.

No matter what i do in the TRD file I have this error.

Can someone help me on this issue ? 
 
 
mw_uahmad
Posted: Jun 17, 2005 - 03:47 PM   

Our flash programmer seems to support the following flash configuration: part: am29pl160cb and has 1M x 16 x 1 of flash. Yours is 2mb which could be causing problems. I don't believe we have a configuration for a 2mb flash size. You can alternatively use the CFlasher from the freescale website and see if that works. 
 
 
AKULKARNI308
Posted: Jun 22, 2005 - 01:17 AM   

The flash I am using is 1Mx16 bit which is 2mb. Also, I have tried the P&E flash programmer and it works fine. So, basically the hardware is working fine.

The problem is with the configuration of Mwerks programming utility.

The flash I am using is M29W160DB-90N1.

What is the correct procedure to configure it in the source code?
No matter what i do I get the error (as stated in the last email)

Also, whenever I install P&E utility for coldfire my Mwerks IDE does not work .. It gives me some memory error .. i am using Windows 98. Is that a problem ? 
 

mw_uahmad
Posted: Jun 23, 2005 - 06:34 PM   

The flash part you have listed does not seem to be a supported part in both Coldfire 4.x and 5.x. However in 5.x you do have the ability to add a flash device in the Flash programmer's settings. There is not a way to do that in 4.x. If you look in the personality files listings in the Flash programmer panel, your flash part is not listed.


 

Labels (1)
Tags (1)
0 Kudos
0 Replies