New CodeWarrior for MCU V10.7 is available

cancel
Showing results for 
Search instead for 
Did you mean: 

New CodeWarrior for MCU V10.7 is available

New CodeWarrior for MCU V10.7 is available

Greetings,

CodeWarrior for MCU V10.7 is now available for download from nxp.com at
CodeWarrior for Microcontrollers-Eclipse IDE|NXP

157959_157959.pngpastedImage_0.png

 

Major features

  • Combines all the previous CodeWarrior for MCU V10.6.x downloads into a single download and installer
  • Windows 8 and 10 support
  • Added S12Z and S08 device support
  • Updated P&E and Segger debug libraries
  • Various enhancements and bug fixes

See attached release notes for details.

 

It is available as 'offline' and 'online' version:

157958_157958.pngpastedImage_0.png

The offline package contains all architectures supported (ColdFire, ColdFire+, S08, RS08, S12, S12/XGATE, S12Z, DSC, Qorivva, Kinetis), while the online setup executuble contains the common parts, and the selected architectures are downloaded on demand.

The setup will install a 30 day temporary professional license which afterwards default to 'special' edition (code size limited) mode. CodeWarrior for MCU V10.7 is compatible with V10.6 and any existing professional V10.6 license can be used with V10.7. It is not necessary to uinstall any previous CodeWarrior version, as V10.7 can be installed side by side with existing CodeArrior versions.

 

 

NXP CodeWarrior Team

Labels (1)
Attachments
Comments

Hi Erich Styger,This offline package contains all architectures supported (ColdFire, ColdFire+, S08, RS08, S12, S12/XGATE, S12Z, DSC, Qorivva, Kinetis)?

I want to add same S12 derivatives (For example,MC9S12G48).What do I need to do? 

I need to use USBDM,but CodeWarrior5.1/5.2 don't support it.

pastedImage_2.png

pastedImage_3.png

pastedImage_4.png

Hello,

yes, the offline package contains all the architectures shown in your last screenshot. So it supports the S12Z, and *not* the normal S12 you are showing in your previous screenshot:

pastedImage_1.png

If you want to use S12, you have to use Codewarrior (classic, not Eclipse based) 5.x. And yes, USBDM is not included in that installation, but I think you can add it (refer to the USBDM pages for this).

I hope this helps,

Erich

thank you very much!

hi 

     Does this software support MPC5748G development?

Version history
Revision #:
1 of 1
Last update:
‎08-04-2016 02:25 AM
Updated by: