Updating gcc in CodeWarrior?

cancel
Showing results for 
Search instead for 
Did you mean: 

Updating gcc in CodeWarrior?

66 Views
Contributor I

Hi,

We're using "CodeWarrior for Power Architecture Version: 10.5.2 Build Id:160624", which came with gcc 4.9.2.

Specifically we're using "C:\Freescale\CW_PA_v10.5.1\Cross_Tools\gcc-4.9.2-XMe6500-linux".

Our linux OS and libraries are built with a separate tool that uses gcc 5.5.0.

Is there any way to get a version of 5.5.0 (or similar) for our architecture to use in CodeWarrior?

Thanks,

DaveS.

Labels (1)
Tags (2)
0 Kudos
3 Replies

12 Views
Contributor I

Hi Yiping,

I actually solved my own problem - turns out that the shell used to build from CodeWarrior runs in 32 bit mode, but WSL requires 64 bit mode. 

I needed to use the command "\windows\sysnative\wsl make", and all works fine now.

Thanks!

DaveS.

0 Kudos

12 Views
NXP TechSupport
NXP TechSupport
0 Kudos

12 Views
Contributor I

Thanks for that link, and I apologize but we're using the Windows version of CodeWarrior and that doc says it applies to the Linux version only.  Is there a Windows answer?

Btw, I have a Linux version of toolchain I'd really like to use, and tried calling it from an 'external makefile' project by using WSL, but keep getting this error whether I try to run "wsl make" as the build command, run a batch file that invokes "wsl make" or put "wsl" in front of each call to the compiler and linker inside my external makefile:
'wsl' is not recognized as an internal or external command, operable program or batch file.

Is there a way to run wsl based build tools ffrom windows codewarrior?

0 Kudos