Eclipse plugins for Codewarrior (10.6)

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eclipse plugins for Codewarrior (10.6)

1,493 Views
TurboMan
Contributor IV

I use CW10.6 for DSC programming. I've recently been customising eclipse builds and found some useful plugins that make life easier, for example hooking up with SVN using subclipse / subversive. However, I can't add the plugins to Codewarrior.

I then found I need the Eclipse Marketplace installed. I can't add that either. I noticed at this poin there are a few disabled sites in the CodeWarrior sites drop down box.

My questions then are:

1. Is it recommended not to add plugins to Codewarrior 10.6? (or 10.anything?)

2. If it is ok to add in plugins, would this invalidate support / warranty agreements?

3. If it doesn't invalidate support / warranties, how does one go about it?

0 Kudos
1 Reply

950 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

Hi,

CW10.6 is based on Eclipse 4.2. If the plug in supports Eclipse 4.2, Normally, it can be also installed on CW10.6.

There is already some discussion of how to install SVN on CW10. Please refer:

Subversion (SVN) Codewarrior 10 

https://community.nxp.com/thread/382038 


Have a great day,
Jennie Zhang

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos