CodeWarrior 10.2

cancel
Showing results for 
Search instead for 
Did you mean: 

CodeWarrior 10.2

566 Views
dporada
Contributor III

I need to use CW10.2 and MQX3.8.0 for a project.  I think I have everything installed, but ProcessorExpert does not seem to work.  Is there a separate add on for ProcessorExpert?  I have some board files that work only with CW10.2 and MQX3.8.0.

 

It's been a long time since I've used 10.2 and I'm not sure why the ProcessorExpert is blank.

Labels (1)
0 Kudos
7 Replies

272 Views
trytohelp
NXP Employee
NXP Employee

Hi Don,

CW for MCU V10.2 and MQX3.8.0 are old versions (2011).

After to have installed MCU V10.2 and MQXv3.8.0, the project wizard proposes the MQX 3.8 Project.

Processor Expert is working for Kinestis devices.

Refer to the doc under MQX installation folder:

      \Freescale MQX 3.8\doc\tools\cw\SL_MQX_in_CW_10_x.pdf

Page 89 ...

Have a great day,
Pascal
NXP Technical Support

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

272 Views
dporada
Contributor III

I get this message in my Console:

reg.getExtensionPoint is empty

No com.freescale.processorexpert.core.PEservice extension found!

0 Kudos

272 Views
trytohelp
NXP Employee
NXP Employee

Hi Don,

Without more details it's difficult to know what is the problem.

When do you get this message ?

Have a great day,
Pascal
NXP Technical Support

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

272 Views
dporada
Contributor III

Pascal,

I get this when I make a new Bareboard Project with a MK70FN1M0 using processor expert.

0 Kudos

272 Views
trytohelp
NXP Employee
NXP Employee

Hi Don,

Am I missing something ?

Under MY CW for MCU V10.2 installation I've created an project via:

    New ¦ Bareboard Project + Kinetis ¦ K70 Family ¦ K70F (120MHz) Family ¦ MK70FN1M0 ...

I can build PEx code and build the project without problem.

Attached you will find the example created.


Have a great day,
Pascal
NXP Technical Support

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

272 Views
dporada
Contributor III

Pascal,

When I load your project, I cannot open Processor Expert and I get the Console message I mentioned previously.

Is it because I installed the Eval version?

Don

0 Kudos

272 Views
trytohelp
NXP Employee
NXP Employee

Don,

May be there is a problem with your installation.

Can I recommend you to install a new instance of MCU v10.2 ?

Have a great day,
Pascal
NXP Technical Support

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos