Bug Report: K02 Processor Expert HSRUN not allowed

cancel
Showing results for 
Search instead for 
Did you mean: 

Bug Report: K02 Processor Expert HSRUN not allowed

Jump to solution
427 Views
jaydcarlson
Contributor III

When I configure a K02 in Processor Expert to run at full speed, the generated system_MK02F12810.h has this:

#define SYSTEM_SMC_PMPROT_VALUE        0x00U

 

Unless there's Errata that I'm unfamiliar with that this is trying to correct for, this should be changed, as it prevents Processor Expert projects to target the K02 running in HS mode (or any of the low power modes).

 

It should be set to 0xAA:

#define SYSTEM_SMC_PMPROT_VALUE        0xAAU 
Labels (1)
0 Kudos
1 Solution
283 Views
vfilip
NXP Employee
NXP Employee

Hi,

this problem relates to PEx for KSDK 1.2.0, where HS RUN is not automatically enabled when needed. This has been already fixed in PEx for KSDK 1.3.0.

However you can enable this mode in CPU component in "Allowed power modes" group as workaround.

We are sorry for inconvenience.

pastedImage_1.png

best regards

Vojtech Filip

View solution in original post

0 Kudos
3 Replies
283 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

Hi Jay,

thanks you for contacting us.

to solve your problem, please let me know:

1. what SW do you work with? KDS? or Codewwarrior ?

2. what's the CW version?

3. the demo code for this problem.

thanks for your cooperation!


Have a great day,
Zhang Jun

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
283 Views
jaydcarlson
Contributor III

I just noticed this reply. This is in Kinetis Design Studio 3.0.0. Processor Expert Core: 1.4.1;

Processor Expert for Kinetis: 3.0.0. Processor Expert Kinetis SDK Support: 1.2.1.

I don't have any "demo code" to reproduce this problem; it is a bug in the Processor Expert support for the K02. Note that the K22 does *not* have this bug. When I configure either MCU to operate at full speed, the K22 Processor Expert code correctly sets SYSTEM_SMC_PMPROT_VALUE to 0xAA, while the K02 sets it to 0x00.

0 Kudos
284 Views
vfilip
NXP Employee
NXP Employee

Hi,

this problem relates to PEx for KSDK 1.2.0, where HS RUN is not automatically enabled when needed. This has been already fixed in PEx for KSDK 1.3.0.

However you can enable this mode in CPU component in "Allowed power modes" group as workaround.

We are sorry for inconvenience.

pastedImage_1.png

best regards

Vojtech Filip

0 Kudos