problem with USB-TAP under XP mode

cancel
Showing results for 
Search instead for 
Did you mean: 

problem with USB-TAP under XP mode

1,297 Views
MatejPacha
Contributor I

Hi,

I've installed XP mode on Windows 7 32bit and still have problems with USB-TAP connection - anytime I try to attach USB-TAP in USB pane, USB-TAP disappears and LEDs stop blinking. Then I must to reconnect USB-TAP to make it visible in USB pane or in Win7 but this problem comes again. Any idea how to fix it?

 

To check USB-TAP function, I've tried it on another PC with WinXP and its working.

To check possible problem with USB-TAP driver I've installed CodeWarrior for Microcontrollers V6.3 in XP mode and tried to connect with FSLOSBDM and P&E Micro (to 8bit MCU) with the same experience - after Attach the device disappears and LEDs go off.

SofTec with HCS08 SPYDER kit works fine with no connection problems (correctly attached with USB pane in XP mode).

 

Note: CodeWarrior under Win7 is about to crash on every application closing (even if the XP compatibility mode is set and CW runs with administrator account). After several crashes it destroyed itself (cannot start CW).

 

Thanks for any suggestions or experiences

Labels (1)
Tags (1)
0 Kudos
1 Reply

110 Views
kef
Specialist I

I don't have USB-TAP, nor CW for 56xxx, but

 

1) regarding IDE crashes on Win7. Did you try enabling "Disable desktop composition" checkbox in IDE.exe compatibility properties? It helps for IDE's for S08 and S12.

 

2) Regarding operating USB multilink in Windows XP Mode. I managed to make it working, but like you, after Attach blue LED goes off and "USB Device not recognised" pops up. But replugging USB cable turns LED on again, and XP mode windows and applications recognise multilnk. It's weird that only one Attach is required. I'm using quite old USB-ML-12 rev B.

Maybe it matters, I installed V9.01 drivers in XP Mode before first Attach attempt. Clicking Attach for the first time also made blue LED off, but after one or two cable re-plugs XP mode found and installed all required drivers.

0 Kudos