Unresolved breakpoints

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unresolved breakpoints

1,163 Views
ERussell
Contributor IV

I am using CW 10.1 with the K60 development kit.

 

I would like to know why I get the message, "Unresolved breakpoint, An error has been obtained trying to create a breakpoint". I get this message when I click on the arrow next to the check box for the breakpoint in the Breakpoints view. The check box is checked to enable the breakpoint and clicking on the breakpoint correctly brings up the file at the correct location. I am debugging in Flash with the Segger Debug probe which allows 6 breakpoints. I only have one other breakpoint enabled in another file. I am able to set breakpoints in other files that are located in the same folder on the file system as the one in which I am not able to set a breakpoint.

 

 

Thanks.

Labels (1)
0 Kudos
Reply
2 Replies

441 Views
konrada
Contributor IV

I get that regularly in the following situations:

 

  • the source file is accessed through an Eclipse folder link (confuses CW)
  • the source line is in a template (hence, no unique corresponding assembly source line)
  • the source line is in a function which is inlined at every use (hence, no unique corresponding assembly source line

HTH

KA

0 Kudos
Reply

441 Views
ERussell
Contributor IV

Thank you for your reply!

 

My issue is probably the first of the ones you describe because the files in question are linked resources. What I have experienced is that I can successfully set a breakpoint in one line of code in a linked resource file and then not be able to set a breakpoint in the next line of code. I have sent in a technical support question for this problem.

0 Kudos
Reply