CAN tranceiver problem

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

CAN tranceiver problem

Jump to solution
648 Views
binukannur
Contributor III

Hai,

     Iam using freescale DSC controller for automotive application.Using this, I want to use CAN communication. So I used can tranceiver LT1796(http://cds.linear.com/docs/en/datasheet/1796f.pdf)) .

But problem is,  controller is in 3.3v logic level but LTC tranceiver is in 5v operation.

In S08 controller it works fine with this CAN tranceiver.

Can I use 3.3v controller with 5v CAN tranceiver?

If not please suggest a tranceiver IC.

Labels (1)
0 Kudos
1 Solution
344 Views
david_diaz
NXP Employee
NXP Employee

Hello,

Provided you adhere to the DC Electrical Characteristics mentioned on the datasheet, I do not see a problem using the LT1796 transceiver.

Please be aware of the following information:

parameteres.JPG

If the microcontroller can supply the TXD signal with the features needed for the LT1796 transceiver, your application should work correctly.

In order to get more information about the CAN transceivers from Freescale, please refer to the following link:

Controller Area Network (CAN)|Freescale

can transceiver.JPG

Hope this information will be useful for you.

Have a great day.

David

View solution in original post

0 Kudos
2 Replies
345 Views
david_diaz
NXP Employee
NXP Employee

Hello,

Provided you adhere to the DC Electrical Characteristics mentioned on the datasheet, I do not see a problem using the LT1796 transceiver.

Please be aware of the following information:

parameteres.JPG

If the microcontroller can supply the TXD signal with the features needed for the LT1796 transceiver, your application should work correctly.

In order to get more information about the CAN transceivers from Freescale, please refer to the following link:

Controller Area Network (CAN)|Freescale

can transceiver.JPG

Hope this information will be useful for you.

Have a great day.

David

0 Kudos
344 Views
binukannur
Contributor III

Thanks David,

    It works fine. The problem is in my hardware side. I remove the pullup resister that Iam already did.

0 Kudos