Problem with Multilink Rev C  - not running after MCU V10.6 Update3 installed & CW for MCF V7.2

Document created by Pascal Irrle Employee on Jun 15, 2015Last modified by Diana Torres on Feb 28, 2017
Version 4Show Document
  • View in full screen mode

Multilink Rev C is not running after MCU V10.6 Update3

Multilink Rev C is not running under CW for MCF V7.2

                                     

A- Description

 

Problem occurs with Mulitilink Universal Rev C only.

The MCU V10.6 Update 3 is running fine for Mulilink Universal Rev B.

 

With default MCU v10.6 the Multilink Universal Rev C on S12Z board is running fine.

After to have installed the MCU V10.6 Update 3 (+ latest patches/updates - end of May), the first time the debugger is launched, CodeWarrior detects a new firmware is available for Multilink Universal interface.

The firmware is updated automatically.

 

However there is a problem with the new firmware: Usbmlfsufbdmens.0930

In some case it’s not possible to debug an application on board.

 

 

 

B- Solution

 

MCU 10.6 update 3 includes the firmware Usbmlfsufbdmens.0930

However there are some problems with this firmware.

P&E addressed a number of S12 related issues between 9.30 and 9.35.

We recommended users to update to the latest version (Usbmlfsufbdmens.0935) when targeting devices with this debug module.

 

The last version can be download on P&E web site:

                http://www.pemicro.com/downloads/download_file.cfm?download_id=346

 

Attached you will find the update too.

 

The Problem is solved in CodeWarrior MCU V10.6.4

     New CodeWarrior for MCU v10.6.4 available

 

 

C- Other cases – Classic IDE MCF V7.2

 

Configuration: CW for Coldfire V7.2 with Multilink Universal Rev C for ColdFire 54452 Ext FLASH.

Trying to load an application on board, you get an error saying: "Getting flash ID failed”

After to have installed the last P&E firmware, the problem was solved too.

 

To avoid problem – following P&E feedback – we recommend always to install the last P&E update which could be downloaded on P&E web site:

                http://www.pemicro.com/downloads/download_file.cfm?download_id=346

Outcomes